p PatchFirst

CVE-2026-104873

CVE-2026-104873 · LangGraph SDK custom auth silently ignores actions= on resource decorators

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

LangGraph Python SDK is used to connect to running LangGraph API servers, manage assistants, threads and stream runs from Python applications. From 0.1.45 until 0.4.4, the langgraph-sdk resource-scoped authorization decorators @auth.on.threads, @auth.on.assistants, and @auth.on.crons ignore the actions argument and register the selected handler for every action on the resource. Because that wildcard resource handler is selected before broader fallback handlers, an authenticated user may bypass fallback action, ownership, or permission checks and read, update, or delete another user's resource. Only Python deployments using actions on the affected decorators are vulnerable, and a deployment remains protected when the selected handler independently enforces all required checks for every action it receives. This issue is fixed in version 0.4.4.

CVSS 7.6 · Alta · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • langgraph

    Versiones
    • >= 0.1.45, < 0.4.4: Afectada

    Sin corrección publicada

  • langgraph-sdk PyPI

    Versiones
    • 0.1.45
    • 0.1.46
    • 0.1.47
    • 0.1.48
    • 0.1.50
    • 0.1.51
    • 0.1.53
    • 0.1.55
    • 0.1.56
    • 0.1.57
    • 0.1.58
    • 0.1.59
    • 0.1.60
    • 0.1.61
    • 0.1.62
    • 0.1.63
    • 0.1.64
    • 0.1.65
    • 0.1.66
    • 0.1.69
    • 0.1.70
    • 0.1.71
    • 0.1.72
    • 0.1.73
    • 0.1.74
    • 0.2.0
    • 0.2.0a1
    • 0.2.1
    • 0.2.10
    • 0.2.12
    • 0.2.14
    • 0.2.15
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.10
    • 0.3.11
    • 0.3.12
    • 0.3.13
    • 0.3.14
    • 0.3.15
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    • 0.3.8
    • 0.3.9
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.1.45, < 0.4.4

    Actualiza a 0.4.4

Fuentes originales

Comprueba tu servidor →