p PatchFirst

CVE-2026-105746

CVE-2026-105746 · Docling: KServe v2 OCR engine does not enforce enable_remote_services

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.83.0 until 2.131.0, the KServeV2OcrModel class defined in docling/models/stages/ocr/kserve_v2_ocr_model.py sends page images to its configured endpoint without checking the pipeline_options.enable_remote_services setting, even when the caller sets that policy control to false. The StandardPdfPipeline._make_ocr_model method also fails to pass the flag into the OCR factory, allowing remote OCR processing in configurations that rely on remote services being disabled. The destination is configured by the caller rather than selected by an attacker. This issue is fixed in 2.131.0.

CVSS 2.2 · Baja · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • docling

    Versiones
    • >= 2.83.0, < 2.131.0: Afectada

    Sin corrección publicada

  • docling-slim

    Versiones
    • >= 2.83.0, < 2.131.0: Afectada

    Sin corrección publicada

  • docling PyPI

    Versiones
    • 2.100.0
    • 2.101.0
    • 2.102.0
    • 2.102.1
    • 2.102.2
    • 2.103.0
    • 2.104.0
    • 2.105.0
    • 2.106.0
    • 2.107.0
    • 2.108.0
    • 2.109.0
    • 2.110.0
    • 2.111.0
    • 2.112.0
    • 2.113.0
    • 2.114.0
    • 2.115.0
    • 2.116.0
    • 2.117.0
    • 2.118.0
    • 2.118.1
    • 2.119.0
    • 2.120.1
    • 2.120.2
    • 2.120.3
    • 2.121.0
    • 2.122.0
    • 2.123.0
    • 2.123.1
    • 2.124.0
    • 2.125.0
    • 2.126.0
    • 2.127.0
    • 2.128.0
    • 2.129.0
    • 2.130.0
    • 2.83.0
    • 2.84.0
    • 2.85.0
    • 2.86.0
    • 2.87.0
    • 2.88.0
    • 2.89.0
    • 2.90.0
    • 2.91.0
    • 2.92.0
    • 2.93.0
    • 2.94.0
    • 2.95.0
    • 2.96.0
    • 2.96.1
    • 2.97.0
    • 2.98.0
    • 2.99.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.83.0, < 2.131.0

    Actualiza a 2.131.0

Fuentes originales

Comprueba tu servidor →