CVE-2026-106441
CVE-2026-106441 · Hydra logging configuration permits unsafe callable resolution
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Hydra is a framework for elegantly configuring complex applications. Prior to 1.3.6 and 1.4.0.dev9, Hydra passes Python logging configuration to logging.config.dictConfig() without applying Hydra's target policy to handler class values or formatter, filter, handler, queue, and listener factories. An attacker who controls Hydra logging configuration can therefore select an importable class or factory and cause it to be invoked with the application's privileges, even in versions where instantiate() is protected because the logging path does not use instantiate(). This issue is fixed in versions 1.3.6 and 1.4.0.dev9.
CVSS 7.8 · Alta · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
hydra
- Versiones
- < 1.3.6: Afectada
- >= 1.4.0.dev0, < 1.4.0.dev9: Afectada
Sin corrección publicada
hydra-core PyPI
- Versiones
- 0.1.4
- 0.1.5
- 0.1.5rc1
- 0.10.0
- 0.11.0
- 0.11.0rc1
- 0.11.1
- 0.11.1rc1
- 0.11.2
- 0.11.2rc1
- 0.11.3
- 0.9.0
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.0.0rc4
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.1.0
- 1.1.0.dev1
- 1.1.0.dev2
- 1.1.0.dev3
- 1.1.0.dev4
- 1.1.0.dev5
- 1.1.0.dev6
- 1.1.0.dev7
- 1.1.0rc1
- 1.1.1
- 1.1.2
- 1.1.2.dev0
- 1.2.0
- 1.2.0.dev1
- 1.2.0.dev2
- 1.2.0.dev3
- 1.2.0.dev4
- 1.2.0.dev5
- 1.3.0
- 1.3.0.dev0
- 1.3.0.dev1
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.6
Actualiza a 1.3.6
hydra-core PyPI
- Versiones
- 1.4.0.dev1
- 1.4.0.dev3
- 1.4.0.dev4
- 1.4.0.dev5
- 1.4.0.dev6
- 1.4.0.dev8
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.4.0.dev0, < 1.4.0.dev9
Actualiza a 1.4.0.dev9
hydra-core PyPI
- Versiones
- 0.1.4
- 0.1.5
- 0.1.5rc1
- 0.10.0
- 0.11.0
- 0.11.0rc1
- 0.11.1
- 0.11.1rc1
- 0.11.2
- 0.11.2rc1
- 0.11.3
- 0.9.0
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.0.0rc4
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.1.0
- 1.1.0.dev1
- 1.1.0.dev2
- 1.1.0.dev3
- 1.1.0.dev4
- 1.1.0.dev5
- 1.1.0.dev6
- 1.1.0.dev7
- 1.1.0rc1
- 1.1.1
- 1.1.2
- 1.1.2.dev0
- 1.2.0
- 1.2.0.dev1
- 1.2.0.dev2
- 1.2.0.dev3
- 1.2.0.dev4
- 1.2.0.dev5
- 1.3.0
- 1.3.0.dev0
- 1.3.0.dev1
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.4.0.dev1
- 1.4.0.dev3
- 1.4.0.dev4
- 1.4.0.dev5
- 1.4.0.dev6
- 1.4.0.dev8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.6 ∪ ≥ 1.4.0.dev0, < 1.4.0.dev9
Actualiza a 1.3.6; Actualiza a 1.4.0.dev9
Fuentes originales
- https://github.com/hydra-ecosystem/hydra/security/advisories/GHSA-c3wx-c55w-pxjq
- https://github.com/hydra-ecosystem/hydra/pull/3420
- https://github.com/hydra-ecosystem/hydra/commit/76bfc30ce1f3105416941dd2e3a562568e369120
- https://github.com/hydra-ecosystem/hydra/commit/ff3e4dba890c29a21d8c2bb867ee87d37ccf21d0
- https://nvd.nist.gov/vuln/detail/CVE-2026-106441