CVE-2026-106444
CVE-2026-106444 · Handlebars: JavaScript Injection via Unsafe Inline Embedding of Precompiled Templates
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Handlebars provides the power necessary to let users build semantic templates. From 4.0.0 until 4.7.10, Handlebars.precompile() uses quotedString() in lib/handlebars/compiler/code-gen.js to emit static template text into generated JavaScript without escaping sequences that terminate an enclosing HTML script element. When an application precompiles attacker-controlled template text and embeds the generated source directly in an inline script element, a closing script delimiter can end the element and cause following attacker-controlled markup to be parsed and executed. Ordinary server-side rendering and precompiled templates served as external JavaScript files are not affected. This issue is fixed in version 4.7.10.
CVSS 4.7 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
handlebars.js
- Versiones
- >= 4.0.0, < 4.7.10: Afectada
Sin corrección publicada
node-handlebars Debian:12
- Versiones
- 3:4.7.10-1
- 3:4.7.7+~4.1.0-1
- 3:4.7.9-1
- 3:4.7.9-2
- 3:4.7.9-3
- 3:4.7.9-4
- 3:4.7.9-5
- 3:4.7.9-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Debian:13
- Versiones
- 3:4.7.10-1
- 3:4.7.7+~4.1.0-1
- 3:4.7.9-1
- 3:4.7.9-2
- 3:4.7.9-3
- 3:4.7.9-4
- 3:4.7.9-5
- 3:4.7.9-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Debian:14
- Versiones
- 3:4.7.7+~4.1.0-1
- 3:4.7.9-1
- 3:4.7.9-2
- 3:4.7.9-3
- 3:4.7.9-4
- 3:4.7.9-5
- 3:4.7.9-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 3:4.7.10-1
Actualiza a 3:4.7.10-1
handlebars npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 4.7.10
Actualiza a 4.7.10
ruby-handlebars-assets Ubuntu:16.04:LTS
- Versiones
- 0.15-2
- 2:0.20.2-2
- 2:0.21.0-2
- 2:0.21.0-3
- 2:0.21.0-4
- 2:0.21.0-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Ubuntu:18.04:LTS
- Versiones
- 3:4.0.10-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby-handlebars-assets Ubuntu:18.04:LTS
- Versiones
- 2:0.23.1-1
- 2:0.23.2-2
- 2:0.23.2+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Ubuntu:20.04:LTS
- Versiones
- 3:4.1.0-1
- 3:4.5.3-1
- 3:4.7.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby-handlebars-assets Ubuntu:20.04:LTS
- Versiones
- 2:0.23.3+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Ubuntu:22.04:LTS
- Versiones
- 3:4.7.6+~4.1.0-2
- 3:4.7.7+~4.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby-handlebars-assets Ubuntu:22.04:LTS
- Versiones
- 2:0.23.8+dfsg-3
- 2:0.23.8+dfsg-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Ubuntu:24.04:LTS
- Versiones
- 3:4.7.7+~4.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby-handlebars-assets Ubuntu:24.04:LTS
- Versiones
- 2:0.23.9+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Ubuntu:26.10
- Versiones
- 3:4.7.7+~4.1.0-1
- 3:4.7.9-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-handlebars Ubuntu:26.04:LTS
- Versiones
- 3:4.7.7+~4.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/handlebars-lang/handlebars.js/security/advisories/GHSA-xw65-4hp5-5hc7
- https://github.com/handlebars-lang/handlebars.js/pull/2185
- https://github.com/handlebars-lang/handlebars.js/commit/609d1b11c833c9a3e00f56f2f34d22f425446725
- https://github.com/handlebars-lang/handlebars.js/releases/tag/v4.7.10
- https://nvd.nist.gov/vuln/detail/CVE-2026-106444