CVE-2026-107289
CVE-2026-107289 · Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv6 zone identifier (incomplete fix for CVE-2026-46678 and CVE-2026-48782)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 1.56.0 until 1.107.6 and 2.44.0, applications that opt attacker-influenced URLs into local network access through FileUrl with force_download='allow-local' or web_fetch_tool with allow_local_urls=True can bypass the cloud-metadata blocklist by appending an IPv6 zone identifier to an IPv6 metadata address. IPv6Address equality and hashing include the zone identifier, so the blocklist comparison fails even though the network stack ignores the zone on a non-link-local destination and reaches the metadata service, potentially exposing cloud IAM credentials. The opt-in settings are disabled by default, and the issue requires an IPv6-enabled environment. This issue is fixed in versions 1.107.6 and 2.44.0.
CVSS 6.8 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
pydantic-ai
- Versiones
- >= 1.56.0, < 1.107.6: Afectada
- >= 2.0.0b1, < 2.44.0: Afectada
Sin corrección publicada
pydantic-ai-slim
- Versiones
- >= 1.56.0, < 1.107.6: Afectada
- >= 2.0.0b1, < 2.44.0: Afectada
Sin corrección publicada
pydantic-ai PyPI
- Versiones
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.107.2
- 1.107.4
- 1.107.5
- 1.56.0
- 1.57.0
- 1.58.0
- 1.59.0
- 1.60.0
- 1.61.0
- 1.62.0
- 1.63.0
- 1.64.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.56.0, < 1.107.6
Actualiza a 1.107.6
pydantic-ai PyPI
- Versiones
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.24.0
- 2.25.0
- 2.26.0
- 2.27.0
- 2.27.1
- 2.28.0
- 2.29.0
- 2.3.0
- 2.30.0
- 2.31.0
- 2.31.1
- 2.32.0
- 2.32.1
- 2.32.2
- 2.33.0
- 2.34.0
- 2.35.0
- 2.35.1
- 2.35.3
- 2.36.0
- 2.37.0
- 2.38.0
- 2.39.0
- 2.4.0
- 2.40.0
- 2.41.0
- 2.42.0
- 2.43.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0b1, < 2.44.0
Actualiza a 2.44.0
pydantic-ai-slim PyPI
- Versiones
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.107.2
- 1.107.4
- 1.107.5
- 1.56.0
- 1.57.0
- 1.58.0
- 1.59.0
- 1.60.0
- 1.61.0
- 1.62.0
- 1.63.0
- 1.64.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.56.0, < 1.107.6
Actualiza a 1.107.6
pydantic-ai-slim PyPI
- Versiones
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.24.0
- 2.25.0
- 2.26.0
- 2.27.0
- 2.27.1
- 2.28.0
- 2.29.0
- 2.3.0
- 2.30.0
- 2.31.0
- 2.31.1
- 2.32.0
- 2.32.1
- 2.32.2
- 2.33.0
- 2.34.0
- 2.35.0
- 2.35.1
- 2.35.3
- 2.36.0
- 2.37.0
- 2.38.0
- 2.39.0
- 2.4.0
- 2.40.0
- 2.41.0
- 2.42.0
- 2.43.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0b1, < 2.44.0
Actualiza a 2.44.0
pydantic-ai PyPI
- Versiones
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.107.2
- 1.107.4
- 1.107.5
- 1.56.0
- 1.57.0
- 1.58.0
- 1.59.0
- 1.60.0
- 1.61.0
- 1.62.0
- 1.63.0
- 1.64.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.24.0
- 2.25.0
- 2.26.0
- 2.27.0
- 2.27.1
- 2.28.0
- 2.29.0
- 2.3.0
- 2.30.0
- 2.31.0
- 2.31.1
- 2.32.0
- 2.32.1
- 2.32.2
- 2.33.0
- 2.34.0
- 2.35.0
- 2.35.1
- 2.35.3
- 2.36.0
- 2.37.0
- 2.38.0
- 2.39.0
- 2.4.0
- 2.40.0
- 2.41.0
- 2.42.0
- 2.43.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.56.0, < 1.107.6 ∪ ≥ 2.0.0b1, < 2.44.0
Actualiza a 1.107.6; Actualiza a 2.44.0
pydantic-ai-slim PyPI
- Versiones
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.107.2
- 1.107.4
- 1.107.5
- 1.56.0
- 1.57.0
- 1.58.0
- 1.59.0
- 1.60.0
- 1.61.0
- 1.62.0
- 1.63.0
- 1.64.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.24.0
- 2.25.0
- 2.26.0
- 2.27.0
- 2.27.1
- 2.28.0
- 2.29.0
- 2.3.0
- 2.30.0
- 2.31.0
- 2.31.1
- 2.32.0
- 2.32.1
- 2.32.2
- 2.33.0
- 2.34.0
- 2.35.0
- 2.35.1
- 2.35.3
- 2.36.0
- 2.37.0
- 2.38.0
- 2.39.0
- 2.4.0
- 2.40.0
- 2.41.0
- 2.42.0
- 2.43.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.56.0, < 1.107.6 ∪ ≥ 2.0.0b1, < 2.44.0
Actualiza a 1.107.6; Actualiza a 2.44.0
Fuentes originales
- https://github.com/pydantic/pydantic-ai/security/advisories/GHSA-vmxc-h2x2-jmf3
- https://github.com/pydantic/pydantic-ai/pull/8401
- https://github.com/pydantic/pydantic-ai/pull/8402
- https://github.com/pydantic/pydantic-ai/commit/02157e1b87bd45d3f2e111ce07afdf89f9fb0e5b
- https://github.com/pydantic/pydantic-ai/commit/4da70591460f51a8c4f128eaeef70a33340dbd55
- https://github.com/pydantic/pydantic-ai/releases/tag/v1.107.6
- https://github.com/pydantic/pydantic-ai/releases/tag/v2.44.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-107289