CVE-2026-109869
CVE-2026-109869 · undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.
CVSS 7.5 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
undici
- Versiones
- ≥ 6.23.0, < 6.29.1: Afectada (semver)
- 6.29.1: No afectada (semver)
- ≥ 7.18.0, < 7.30.1: Afectada (semver)
- 7.30.1: No afectada (semver)
- ≥ 8.0.0, < 8.12.2: Afectada (semver)
- 8.12.2: No afectada (semver)
Actualiza a 6.29.1; Actualiza a 7.30.1; Actualiza a 8.12.2
node-undici Debian:12
- Versiones
- 5.15.0+dfsg1+~cs20.10.9.3-1
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u2
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4
- 5.19.1+dfsg1+~cs20.10.9.5-1
- 5.19.1+dfsg1+~cs20.10.9.5-2
- 5.22.1+dfsg1+~cs20.10.10.2-1
- 5.26.3+dfsg1+~cs23.10.12-1
- 5.26.3+dfsg1+~cs23.10.12-2
- 5.26.3+dfsg1+~cs23.10.12-3
- 5.28.0+dfsg1+~cs23.11.12.3-1
- 5.28.0+dfsg1+~cs23.11.12.3-2
- 5.28.2+dfsg1+~cs23.11.12.3-1
- 5.28.2+dfsg1+~cs23.11.12.3-2
- 5.28.2+dfsg1+~cs23.11.12.3-3
- 5.28.2+dfsg1+~cs23.11.12.3-4
- 5.28.2+dfsg1+~cs23.11.12.3-5
- 5.28.2+dfsg1+~cs23.11.12.3-6
- 5.28.4+dfsg1+~cs23.12.11-1
- 5.28.4+dfsg1+~cs23.12.11-2
- 7.1.0+dfsg1+~cs24.12.10-1
- 7.15.0+dfsg+~cs3.2.0-1
- 7.15.0+dfsg+~cs3.2.0-3
- 7.16.0+dfsg+~cs3.2.0-1
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.2.3+dfsg1+~cs24.12.11-1
- 7.2.3+dfsg1+~cs24.12.11-2
- 7.24.5+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-2
- 7.24.6+dfsg+~cs3.2.0-3
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- 8.10.2+dfsg+~cs3.2.2-1
- 8.12.1+dfsg+~cs3.2.3-1
- 8.12.2+dfsg+~cs3.2.3-1
- 8.12.2+dfsg+~cs3.2.3-2
- 8.5.0+dfsg+~cs3.2.0-1
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Debian:13
- Versiones
- 7.15.0+dfsg+~cs3.2.0-1
- 7.15.0+dfsg+~cs3.2.0-3
- 7.16.0+dfsg+~cs3.2.0-1
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.24.5+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-2
- 7.24.6+dfsg+~cs3.2.0-3
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- 8.10.2+dfsg+~cs3.2.2-1
- 8.12.1+dfsg+~cs3.2.3-1
- 8.12.2+dfsg+~cs3.2.3-1
- 8.12.2+dfsg+~cs3.2.3-2
- 8.5.0+dfsg+~cs3.2.0-1
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Debian:14
- Versiones
- 7.15.0+dfsg+~cs3.2.0-1
- 7.15.0+dfsg+~cs3.2.0-3
- 7.16.0+dfsg+~cs3.2.0-1
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.24.5+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-2
- 7.24.6+dfsg+~cs3.2.0-3
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- 8.10.2+dfsg+~cs3.2.2-1
- 8.12.1+dfsg+~cs3.2.3-1
- 8.12.2+dfsg+~cs3.2.3-1
- 8.12.2+dfsg+~cs3.2.3-2
- 8.5.0+dfsg+~cs3.2.0-1
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
undici npm
- Intervalos de versiones afectados
- SEMVER: ≥ 6.23.0, < 6.29.1
Actualiza a 6.29.1
undici npm
- Intervalos de versiones afectados
- SEMVER: ≥ 7.18.0, < 7.30.1
Actualiza a 7.30.1
undici npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.12.2
Actualiza a 8.12.2
node-undici Ubuntu:24.04:LTS
- Versiones
- 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
- 5.26.3+dfsg1+~cs23.10.12-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Ubuntu:26.10
- Versiones
- 7.18.2+dfsg+~cs3.2.0-1build1
- 7.24.6+dfsg+~cs3.2.0-3
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Ubuntu:26.04:LTS
- Versiones
- 7.3.0+dfsg1+~cs24.12.11-2
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.18.2+dfsg+~cs3.2.0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada