CVE-2026-110095
CVE-2026-110095 · fast-uri vulnerable to improper path equivalence in relative reference normalization
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the reference beforehand.
CVSS 3.7 · Baja · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
fast-uri
- Versiones
- ≥ 0, < 2.4.8: Afectada (semver)
- 2.4.8: No afectada (semver)
- ≥ 3.0.0, < 3.1.9: Afectada (semver)
- 3.1.9: No afectada (semver)
- ≥ 4.0.0, < 4.2.3: Afectada (semver)
- 4.2.3: No afectada (semver)
Actualiza a 2.4.8; Actualiza a 3.1.9; Actualiza a 4.2.3
node-ajv Debian:12
- Versiones
- 6.12.6-3
- 8.11.2~ds+~2.1.1-1
- 8.12.0~ds+~2.1.1-1
- 8.12.0~ds+~2.1.1-2
- 8.12.0~ds+~2.1.1-3
- 8.12.0~ds+~2.1.1-4
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- 8.20.0~ds+~cs7.1.4-1
- 8.20.0~ds+~cs7.1.5-1
- 8.20.0~ds+~cs7.1.6-1
- 8.20.0~ds+~cs7.1.6-2
- 8.20.0~ds+~cs7.2.4-1
- 8.8.2~ds+~2.1.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ajv Debian:13
- Versiones
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- 8.20.0~ds+~cs7.1.4-1
- 8.20.0~ds+~cs7.1.5-1
- 8.20.0~ds+~cs7.1.6-1
- 8.20.0~ds+~cs7.1.6-2
- 8.20.0~ds+~cs7.2.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ajv Debian:14
- Versiones
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- 8.20.0~ds+~cs7.1.4-1
- 8.20.0~ds+~cs7.1.5-1
- 8.20.0~ds+~cs7.1.6-1
- 8.20.0~ds+~cs7.1.6-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.20.0~ds+~cs7.2.4-1
Actualiza a 8.20.0~ds+~cs7.2.4-1
fast-uri npm
- Intervalos de versiones afectados
- SEMVER: < 2.4.8
Actualiza a 2.4.8
fast-uri npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.0.0, < 3.1.9
Actualiza a 3.1.9
fast-uri npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 4.2.3
Actualiza a 4.2.3
node-ajv Ubuntu:18.04:LTS
- Versiones
- 5.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ajv Ubuntu:20.04:LTS
- Versiones
- 6.10.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ajv Ubuntu:22.04:LTS
- Versiones
- 6.12.6-2
- 6.12.6-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ajv Ubuntu:24.04:LTS
- Versiones
- 6.12.6-3
- 8.12.0~ds+~2.1.1-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ajv Ubuntu:26.10
- Versiones
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ajv Ubuntu:26.04:LTS
- Versiones
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada