p PatchFirst

CVE-2026-110725

CVE-2026-110725 · fast-uri vulnerable to scheme injection via an unescaped first-segment colon in suffix references

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, when serialize(), normalize(), or resolve() are called with the non-default option reference set to suffix on a reference that has no authority, the emitted relative reference can contain a bare colon in its first path segment without escaping it, even though RFC 3986 forbids that because it makes the string reparse as an absolute URI with a scheme. An application that serializes or normalizes a relative reference with the suffix option and then treats the result as a URI can turn inert input into a live javascript, data, or vbscript URL, a cross-site scripting vector, and the equal() comparison can conflate a scheme-bearing reference with a relative one. Exposure is limited to applications using the non-default suffix reference option. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, avoid the suffix reference option on untrusted input, or percent-encode a colon in the first path segment of the result before treating it as a URI.

CVSS 3.7 · Baja · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • fast-uri

    Versiones
    • ≥ 0, < 2.4.8: Afectada (semver)
    • 2.4.8: No afectada (semver)
    • ≥ 3.0.0, < 3.1.9: Afectada (semver)
    • 3.1.9: No afectada (semver)
    • ≥ 4.0.0, < 4.2.3: Afectada (semver)
    • 4.2.3: No afectada (semver)

    Actualiza a 2.4.8; Actualiza a 3.1.9; Actualiza a 4.2.3

  • node-ajv Debian:12

    Versiones
    • 6.12.6-3
    • 8.11.2~ds+~2.1.1-1
    • 8.12.0~ds+~2.1.1-1
    • 8.12.0~ds+~2.1.1-2
    • 8.12.0~ds+~2.1.1-3
    • 8.12.0~ds+~2.1.1-4
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    • 8.20.0~ds+~cs7.2.4-1
    • 8.8.2~ds+~2.1.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Debian:13

    Versiones
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    • 8.20.0~ds+~cs7.2.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Debian:14

    Versiones
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 8.20.0~ds+~cs7.2.4-1

    Actualiza a 8.20.0~ds+~cs7.2.4-1

  • fast-uri npm

    Intervalos de versiones afectados
    • SEMVER: < 2.4.8

    Actualiza a 2.4.8

  • fast-uri npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.1.9

    Actualiza a 3.1.9

  • fast-uri npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.2.3

    Actualiza a 4.2.3

Fuentes originales

Comprueba tu servidor →