p PatchFirst

CVE-2026-114614

CVE-2026-114614 · Authlib: is_secure_transport() loopback exemption can be bypassed with a userinfo component, allowing cleartext-HTTP URLs to non-loopback hosts

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Authlib is a Python library which builds OAuth and OpenID Connect servers. From 0.13 until 1.8.0, authlib.common.security.is_secure_transport() uses a textual prefix comparison for loopback HTTP exemptions, so a URL whose userinfo begins with a loopback host can be accepted even when its parsed host is an external non-loopback system. An external party able to supply a URL to OIDC RP-Initiated Logout registration, authorization-server metadata validation, or another call site can bypass the TLS-required guard and cause cleartext redirection or acceptance of cleartext endpoints. The issue does not bypass redirect URI exact matching and does not by itself forge tokens or authenticate users. The vulnerable authlib.common.security.is_secure_transport() implementation in authlib/common/security.py misinterprets the userinfo component before OIDC RP-Initiated Logout dynamic client registration and other consumers enforce transport security. This issue is fixed in version 1.8.0.

CVSS 2.6 · Baja · EPSS 0,2% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • authlib

    Versiones
    • < 1.8.0: Afectada

    Sin corrección publicada

  • python-authlib Debian:12

    Versiones
    • 1.2.0-1
    • 1.2.0-1+deb12u1
    • 1.2.0-1+deb12u2
    • 1.2.1-1
    • 1.3.0-1
    • 1.3.0-2
    • 1.3.0-3
    • 1.3.1-1
    • 1.3.2-1
    • 1.3.2-2
    • 1.4.0-1
    • 1.4.1-1
    • 1.5.0-1
    • 1.5.1-1
    • 1.5.2-1
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    • 1.6.8-1
    • 1.6.9-1
    • 1.7.0-1
    • 1.7.2-1
    • 1.7.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-authlib Debian:13

    Versiones
    • 1.6.0-1
    • 1.6.0-1+deb13u1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    • 1.6.8-1
    • 1.6.9-1
    • 1.7.0-1
    • 1.7.2-1
    • 1.7.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-authlib Debian:14

    Versiones
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    • 1.6.8-1
    • 1.6.9-1
    • 1.7.0-1
    • 1.7.2-1
    • 1.7.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • authlib PyPI

    Versiones
    • 0.1
    • 0.10
    • 0.11
    • 0.12
    • 0.12.1
    • 0.13
    • 0.14
    • 0.14.1
    • 0.14.2
    • 0.14.3
    • 0.15
    • 0.15.1
    • 0.15.2
    • 0.15.3
    • 0.15.4
    • 0.15.5
    • 0.15.6
    • 0.1rc0
    • 0.2
    • 0.2.1
    • 0.3
    • 0.4
    • 0.4.1
    • 0.5
    • 0.5.1
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 1.0.0
    • 1.0.0a1
    • 1.0.0a2
    • 1.0.0b1
    • 1.0.0b2
    • 1.0.0rc1
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.10
    • 1.6.11
    • 1.6.12
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.6.7
    • 1.6.8
    • 1.6.9
    • 1.7.0
    • 1.7.1
    • 1.7.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.8.0

    Actualiza a 1.8.0

  • python-authlib Ubuntu:Pro:22.04:LTS

    Versiones
    • 0.15.4-1
    • 0.15.5-1
    • 0.15.5-1ubuntu0.1~esm1
    • 0.15.5-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-authlib Ubuntu:Pro:24.04:LTS

    Versiones
    • 1.2.1-1
    • 1.3.0-1
    • 1.3.0-1ubuntu0.1~esm1
    • 1.3.0-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-authlib Ubuntu:26.10

    Versiones
    • 1.6.7-1
    • 1.7.2-1
    • 1.7.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-authlib Ubuntu:Pro:26.04:LTS

    Versiones
    • 1.6.0-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    • 1.6.7-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →