p PatchFirst

CVE-2026-115910

CVE-2026-115910 · Python Social Auth: OpenID Connect nonce is not bound to the browser session, so a stolen authorization code logs the attacker in as the victim

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Python Social Auth is a social authentication and registration mechanism. Prior to 6.2.0, OpenIdConnectAuth in social_core/backends/open_id_connect.py uses get_and_store_nonce to place the OpenID Connect nonce in a shared OpenIdConnectAssociation table, and get_nonce and validate_claims verify only that the nonce exists and has not expired rather than binding it to the browser session and OAuth state that initiated the login. An attacker who obtains a victim's unused authorization code can start a separate login to obtain valid state for the attacker's browser, submit the victim's code with that state, and pass nonce validation because the victim nonce is globally available. With DEFAULT_USE_PKCE disabled in the default OpenIdConnectAuth configuration, the attacker can be logged in as the victim. This issue is fixed in version 6.2.0.

CVSS 6.8 · Media

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • social-core

    Versiones
    • < 6.2.0: Afectada

    Sin corrección publicada

  • social-auth-core Debian:12

    Versiones
    • 4.3.0-1
    • 4.4.2-1
    • 4.4.2-2
    • 4.5.3-1
    • 4.5.4-1
    • 4.5.6-1
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • social-auth-core Debian:13

    Versiones
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • social-auth-core Debian:14

    Versiones
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →