CVE-2026-115915
CVE-2026-115915 · vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
CVSS 8.1 · Alta · EPSS 0,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
vllm
- Versiones
- < 0.32.0: Afectada
Sin corrección publicada
vllm PyPI
- Versiones
- 0.0.1
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.10.0
- 0.10.1
- 0.10.1.1
- 0.10.2
- 0.11.0
- 0.11.1
- 0.11.2
- 0.12.0
- 0.13.0
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.16.0
- 0.17.0
- 0.17.1
- 0.18.0
- 0.18.1
- 0.19.0
- 0.19.1
- 0.2.0
- 0.2.1
- 0.2.1.post1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.22.0
- 0.22.1
- 0.23.0
- 0.24.0
- 0.25.0
- 0.25.1
- 0.26.0
- 0.27.0
- 0.27.1
- 0.28.0
- 0.29.0
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.30.0
- 0.31.0
- 0.4.0
- 0.4.0.post1
- 0.4.1
- 0.4.2
- 0.4.3
- 0.5.0
- 0.5.0.post1
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.3.post1
- 0.5.4
- 0.5.5
- 0.6.0
- 0.6.1
- 0.6.1.post1
- 0.6.1.post2
- 0.6.2
- 0.6.3
- 0.6.3.post1
- 0.6.4
- 0.6.4.post1
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5.post1
- 0.9.0
- 0.9.0.1
- 0.9.1
- 0.9.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.32.0
Actualiza a 0.32.0
vllm PyPI
- Versiones
- 0.30.0
- 0.31.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.30.0, < 0.32.0
Actualiza a 0.32.0
Fuentes originales
- https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h
- https://github.com/vllm-project/vllm/pull/60022
- https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-115915