CVE-2026-115918
CVE-2026-115918 · vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.
CVSS 6.5 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
vllm
- Versiones
- >= 0.16.0, < 0.32.0: Afectada
Sin corrección publicada
vllm PyPI
- Versiones
- 0.16.0
- 0.17.0
- 0.17.1
- 0.18.0
- 0.18.1
- 0.19.0
- 0.19.1
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.22.0
- 0.22.1
- 0.23.0
- 0.24.0
- 0.25.0
- 0.25.1
- 0.26.0
- 0.27.0
- 0.27.1
- 0.28.0
- 0.29.0
- 0.30.0
- 0.31.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.16.0, < 0.32.0
Actualiza a 0.32.0
Fuentes originales
- https://github.com/vllm-project/vllm/security/advisories/GHSA-x567-49g5-p4cf
- https://github.com/vllm-project/vllm/pull/50300
- https://github.com/vllm-project/vllm/commit/cff08b461e086523cee8bba5bd3c66d302625134
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-115918