p PatchFirst

CVE-2026-116691

CVE-2026-116691 · MLflow CrewAI autologging records LLM provider API keys in logged trace spans

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

MLflow is an open source AI engineering platform for agents, large language models, and machine learning models. From 2.19.0 until 3.17.0, mlflow.crewai.autolog() records CrewAI Agent objects without consistently sanitizing nested credential-bearing values. mlflow/crewai/autolog.py::_get_agent_attributes() converts the Agent llm field to a string that includes the provider API key, while mlflow/crewai/autolog.py::_construct_full_inputs() expands the Agent object into mlflow.spanInputs. Applications can therefore send plaintext provider credentials to the MLflow trace backend or a configured OTLP destination, where trace readers can obtain them. This issue is fixed in version 3.17.0.

CVSS 6.5 · Media · EPSS 0,2% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • mlflow

    Versiones
    • >= 2.19.0, < 3.17.0: Afectada

    Sin corrección publicada

  • mlflow PyPI

    Versiones
    • 2.19.0
    • 2.20.0
    • 2.20.0rc0
    • 2.20.1
    • 2.20.2
    • 2.20.3
    • 2.20.4
    • 2.21.0
    • 2.21.0rc0
    • 2.21.1
    • 2.21.2
    • 2.21.3
    • 2.22.0
    • 2.22.0rc0
    • 2.22.1
    • 2.22.2
    • 2.22.3
    • 2.22.4
    • 2.22.5
    • 3.0.0
    • 3.0.0rc0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.1
    • 3.1.0
    • 3.1.0rc0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.1.4
    • 3.10.0
    • 3.10.0rc0
    • 3.10.1
    • 3.11.0
    • 3.11.0rc0
    • 3.11.0rc1
    • 3.11.1
    • 3.12.0
    • 3.12.0rc0
    • 3.13.0
    • 3.13.0rc0
    • 3.14.0
    • 3.15.0
    • 3.15.1
    • 3.15.2
    • 3.16.0
    • 3.16.1
    • 3.2.0
    • 3.2.0rc0
    • 3.3.0
    • 3.3.0rc0
    • 3.3.1
    • 3.3.2
    • 3.4.0
    • 3.4.0rc0
    • 3.5.0
    • 3.5.0rc0
    • 3.5.1
    • 3.6.0
    • 3.6.0rc0
    • 3.7.0
    • 3.7.0rc0
    • 3.8.0
    • 3.8.0rc0
    • 3.8.1
    • 3.9.0
    • 3.9.0rc0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.19.0, < 3.17.0

    Actualiza a 3.17.0

Fuentes originales

Comprueba tu servidor →