CVE-2026-118764
CVE-2026-118764 · minimatch: potential denial of service via globparts amplification
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
minimatch is a minimal matching utility for converting glob expressions into JavaScript RegExp objects. Starting in 7.0.0 and prior to 11.0.1, src/index.ts implements firstPhasePreProcess() so that, at optimizationLevel 2 or higher, it repeatedly expands attacker-controlled **/.. pattern segments inside a fixpoint loop, allowing generated globParts entries to be processed and expanded again. secondPhasePreProcess() then compares the expanded entries pairwise, so a short malicious glob can cause excessive CPU and memory consumption during pattern compilation. This issue is fixed in version 11.0.1.
CVSS 6.9 · Media · EPSS 0,3% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
minimatch
- Versiones
- >= 7.0.0, < 11.0.1: Afectada
Sin corrección publicada
node-minimatch Debian:12
- Versiones
- 5.1.1+~5.1.2-1
- 9.0.3-1
- 9.0.3-2
- 9.0.3-3
- 9.0.3-4
- 9.0.3-5
- 9.0.3-6
- 9.0.7-1
- 9.0.7-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Debian:13
- Versiones
- 9.0.3-6
- 9.0.7-1
- 9.0.7-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Debian:14
- Versiones
- 9.0.3-6
- 9.0.7-1
- 9.0.7-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
minimatch npm
- Intervalos de versiones afectados
- SEMVER: < 11.0.1
Actualiza a 11.0.1
node-minimatch Ubuntu:Pro:14.04:LTS
- Versiones
- 0.2.11-1
- 0.2.12-1
- 0.2.12-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Ubuntu:Pro:16.04:LTS
- Versiones
- 1.0.0-1
- 1.0.0-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Ubuntu:18.04:LTS
- Versiones
- 3.0.4-1
- 3.0.4-3
- 3.0.4-3+deb10u1build0.18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Ubuntu:20.04:LTS
- Versiones
- 3.0.4-3
- 3.0.4-4
- 3.0.4-4ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Ubuntu:22.04:LTS
- Versiones
- 3.0.4+~3.0.3-1
- 3.0.4+~3.0.5-1
- 3.1.1+~3.0.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Ubuntu:24.04:LTS
- Versiones
- 5.1.1+~5.1.2-1
- 9.0.3-4build5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Ubuntu:26.10
- Versiones
- 9.0.3-6
- 9.0.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-minimatch Ubuntu:26.04:LTS
- Versiones
- 9.0.3-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/isaacs/minimatch/security/advisories/GHSA-g3hv-75wg-m249
- https://github.com/isaacs/minimatch/commit/297b6c1a01f2410b3ba1ebed14ba222d0c3c1033
- https://github.com/isaacs/minimatch/commit/77a0f5c4b80bdc641c3c930a1d9edf5ad2db57f8
- https://github.com/isaacs/minimatch/commit/fd0b3ab9cbc5bf1aff1c99f1f46e413c2b3340da
- https://github.com/isaacs/minimatch/releases/tag/v11.0.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-118764