p PatchFirst

CVE-2026-13311

CVE-2026-13311 · shell-quote parse() is quadratic in token count, enabling denial of service

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

shell-quote prior to 1.8.5 finalizes parsed tokens in parse() using Array.prototype.concat as a reduce accumulator, which reallocates and copies the entire growing array on every iteration. As a result parse() runs in O(n^2) time relative to the number of input tokens. An attacker who can supply an attacker-controlled string to any code path that calls parse() (no shell metacharacters are required; plain space-separated words suffice) can block the single-threaded Node.js event loop for an extended period with a small input, resulting in a denial of service. There is no code execution or data disclosure; impact is to availability only. Fixed in 1.8.5.

CVSS 8.7 · Alta · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • shell-quote

    Versiones
    • ≥ 0, ≤ 1.8.4: Afectada (semver)

    Sin corrección publicada

  • node-shell-quote Debian:12

    Versiones
    • 1.10.0-1
    • 1.12.0-1
    • 1.7.4+~1.7.1-1
    • 1.7.4+~1.7.1-1+deb12u1
    • 1.7.4+~1.7.1-2
    • 1.8.3+~1.7.5-1
    • 1.8.4+~1.7.5-1
    • 1.9.0+~1.7.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-shell-quote Debian:13

    Versiones
    • 1.7.4+~1.7.1-1
    • 1.7.4+~1.7.1-1+deb13u1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.4+~1.7.1-1+deb13u2

    Actualiza a 1.7.4+~1.7.1-1+deb13u2

  • node-shell-quote Debian:14

    Versiones
    • 1.7.4+~1.7.1-1
    • 1.7.4+~1.7.1-2
    • 1.8.3+~1.7.5-1
    • 1.8.4+~1.7.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.9.0+~1.7.5-1

    Actualiza a 1.9.0+~1.7.5-1

  • shell-quote npm

    Intervalos de versiones afectados
    • SEMVER: < 1.9.0

    Actualiza a 1.9.0

  • node-shell-quote Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.6.1+20160617-git72fb5a8ce29b-1
    • 1.6.1+20160617-git72fb5a8ce29b-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-shell-quote Ubuntu:Pro:22.04:LTS

    Versiones
    • 1.7.3+~1.7.1-1
    • 1.7.3+~1.7.1-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-shell-quote Ubuntu:24.04:LTS

    Versiones
    • 1.7.4+~1.7.1-1
    • 1.7.4+~1.7.1-1ubuntu0.24.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-shell-quote Ubuntu:25.10

    Versiones
    • 1.7.4+~1.7.1-1
    • 1.7.4+~1.7.1-1ubuntu0.25.10.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-shell-quote Ubuntu:26.10

    Versiones
    • 1.8.3+~1.7.5-1
    • 1.9.0+~1.7.5-1
    • 1.10.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-shell-quote Ubuntu:Pro:26.04:LTS

    Versiones
    • 1.7.4+~1.7.1-1
    • 1.8.3+~1.7.5-1
    • 1.8.3+~1.7.5-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →