p PatchFirst

CVE-2026-14620

CVE-2026-14620 · webpack-dev-server vulnerable to cross-site request forgery via internal developer endpoints

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

webpack-dev-server versions 5.2.5 and earlier expose two internal developer endpoints, /webpack-dev-server/open-editor and /webpack-dev-server/invalidate, that perform state-changing actions on any GET request without verifying that the request originated from the dev server's own page. Any website a developer visits while the dev server is running can trigger these endpoints cross-origin with no interaction beyond the visit. An attacker can open an arbitrary existing local file in the developer's editor, including files outside the project root, and repeated requests can spawn editor processes and force recompilations that degrade the developer's machine. Patches: upgrade to webpack-dev-server 5.2.6. Workarounds: none.

CVSS 4.7 · Media · EPSS 0,5% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • webpack-dev-server

    Versiones
    • ≥ 0, < 5.2.6: Afectada (semver)
    • 5.2.6: No afectada (semver)

    Actualiza a 5.2.6

  • webpack-dev-server npm

    Intervalos de versiones afectados
    • SEMVER: < 5.2.6

    Actualiza a 5.2.6

Fuentes originales

Comprueba tu servidor →