p PatchFirst

CVE-2026-16434

CVE-2026-16434 · Adminer before 5.5.1 X-Forwarded-Prefix Backslash Bypass

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Adminer 4.6.0 through 5.5.0 (fixed in 5.5.1) contains an incomplete fix for a prior X-Forwarded-Prefix vulnerability (GHSA-8478-xrj3-h9c2). The validation guard (bootstrap.inc.php) only rejects prefixes matching ^/[^/], blocking //evil.com but allowing values such as /\evil.com whose second character is a backslash. Because browsers normalize backslash to forward slash, a network-path reference survives into REQUEST_URI and reaches cookie_path(), affecting the Set-Cookie Path attribute. Exploitation requires that clients can set the X-Forwarded-Prefix header (a misconfigured or absent reverse proxy). Impact is limited to anomalous cookie-path scoping.

CVSS 2.3 · Baja · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • adminer

    Versiones
    • ≥ 0, < 5.5.1: Afectada (semver)
    • 5.5.1: No afectada (semver)

    Actualiza a 5.5.1

  • adminer Debian:12

    Versiones
    • 4.8.1-1
    • 4.8.1-2
    • 4.8.1-4
    • 5.1.0-1
    • 5.2.1+dfsg-1
    • 5.3.0+dfsg-1
    • 5.4.0+dfsg-1
    • 5.4.1+dfsg-1
    • 5.4.2+dfsg-1
    • 5.4.3+dfsg-1
    • 5.4.4+dfsg-1
    • 6.0.0-1
    • 6.0.1-1
    • 6.0.2-1
    • 6.1.0-1
    • 6.1.1-1
    • 6.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Debian:13

    Versiones
    • 5.2.1+dfsg-1
    • 5.3.0+dfsg-1
    • 5.4.0+dfsg-1
    • 5.4.1+dfsg-1
    • 5.4.2+dfsg-1
    • 5.4.3+dfsg-1
    • 5.4.4+dfsg-1
    • 6.0.0-1
    • 6.0.1-1
    • 6.0.2-1
    • 6.1.0-1
    • 6.1.1-1
    • 6.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Debian:14

    Versiones
    • 5.2.1+dfsg-1
    • 5.3.0+dfsg-1
    • 5.4.0+dfsg-1
    • 5.4.1+dfsg-1
    • 5.4.2+dfsg-1
    • 5.4.3+dfsg-1
    • 5.4.4+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 6.0.0-1

    Actualiza a 6.0.0-1

  • adminer Ubuntu:Pro:16.04:LTS

    Versiones
    • 4.2.1-1
    • 4.2.1-1ubuntu1
    • 4.2.1-1ubuntu1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:Pro:18.04:LTS

    Versiones
    • 4.3.1-2
    • 4.5.0-1
    • 4.6.1-1
    • 4.6.2-1
    • 4.6.2-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:Pro:20.04:LTS

    Versiones
    • 4.7.2-1
    • 4.7.4-1
    • 4.7.5-1
    • 4.7.6-1
    • 4.7.6-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:22.04:LTS

    Versiones
    • 4.7.9-2
    • 4.8.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:24.04:LTS

    Versiones
    • 4.8.1-1
    • 4.8.1-1ubuntu1
    • 4.8.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:26.04:LTS

    Versiones
    • 5.2.1+dfsg-1
    • 5.3.0+dfsg-1
    • 5.4.0+dfsg-1
    • 5.4.1+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →