CVE-2026-19534
CVE-2026-19534 · undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
undici's WebSocket client crashes the whole Node.js process during the opening handshake when a server responds with a subprotocol that the client never requested. A default WebSocket connection sends no subprotocol, but if the server's 101 response includes a Sec-WebSocket-Protocol header, undici dereferences a null value while checking it against the requested list and throws an uncaught TypeError. Because that code runs inside a microtask with no surrounding error handling, the exception propagates and terminates the process under Node's default behavior, instead of gracefully failing the connection as required by the WebSocket protocol. Any application that opens a WebSocket to an attacker-controlled or compromised server, or over a plaintext connection subject to a machine-in-the-middle, can be crashed remotely without authentication in the default configuration. This affects undici versions from 6.7.0 up to 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
CVSS 7.5 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
undici
- Versiones
- ≥ 6.7.0, < 6.28.1: Afectada (semver)
- 6.28.1: No afectada (semver)
- ≥ 7.0.0, < 7.29.1: Afectada (semver)
- 7.29.1: No afectada (semver)
- ≥ 8.0.0, < 8.10.2: Afectada (semver)
- 8.10.2: No afectada (semver)
Actualiza a 6.28.1; Actualiza a 7.29.1; Actualiza a 8.10.2
node-undici Debian:12
- Versiones
- 5.15.0+dfsg1+~cs20.10.9.3-1
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u2
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4
- 5.19.1+dfsg1+~cs20.10.9.5-1
- 5.19.1+dfsg1+~cs20.10.9.5-2
- 5.22.1+dfsg1+~cs20.10.10.2-1
- 5.26.3+dfsg1+~cs23.10.12-1
- 5.26.3+dfsg1+~cs23.10.12-2
- 5.26.3+dfsg1+~cs23.10.12-3
- 5.28.0+dfsg1+~cs23.11.12.3-1
- 5.28.0+dfsg1+~cs23.11.12.3-2
- 5.28.2+dfsg1+~cs23.11.12.3-1
- 5.28.2+dfsg1+~cs23.11.12.3-2
- 5.28.2+dfsg1+~cs23.11.12.3-3
- 5.28.2+dfsg1+~cs23.11.12.3-4
- 5.28.2+dfsg1+~cs23.11.12.3-5
- 5.28.2+dfsg1+~cs23.11.12.3-6
- 5.28.4+dfsg1+~cs23.12.11-1
- 5.28.4+dfsg1+~cs23.12.11-2
- 7.1.0+dfsg1+~cs24.12.10-1
- 7.15.0+dfsg+~cs3.2.0-1
- 7.15.0+dfsg+~cs3.2.0-3
- 7.16.0+dfsg+~cs3.2.0-1
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.2.3+dfsg1+~cs24.12.11-1
- 7.2.3+dfsg1+~cs24.12.11-2
- 7.24.5+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-2
- 7.24.6+dfsg+~cs3.2.0-3
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- 8.10.2+dfsg+~cs3.2.2-1
- 8.5.0+dfsg+~cs3.2.0-1
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Debian:13
- Versiones
- 7.15.0+dfsg+~cs3.2.0-1
- 7.15.0+dfsg+~cs3.2.0-3
- 7.16.0+dfsg+~cs3.2.0-1
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.24.5+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-2
- 7.24.6+dfsg+~cs3.2.0-3
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- 8.10.2+dfsg+~cs3.2.2-1
- 8.5.0+dfsg+~cs3.2.0-1
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Debian:14
- Versiones
- 7.15.0+dfsg+~cs3.2.0-1
- 7.15.0+dfsg+~cs3.2.0-3
- 7.16.0+dfsg+~cs3.2.0-1
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.24.5+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-2
- 7.24.6+dfsg+~cs3.2.0-3
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- 8.5.0+dfsg+~cs3.2.0-1
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.10.2+dfsg+~cs3.2.2-1
Actualiza a 8.10.2+dfsg+~cs3.2.2-1
undici npm
- Intervalos de versiones afectados
- SEMVER: ≥ 6.7.0, < 6.28.1
Actualiza a 6.28.1
undici npm
- Intervalos de versiones afectados
- SEMVER: ≥ 7.0.0, < 7.29.1
Actualiza a 7.29.1
undici npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.10.2
Actualiza a 8.10.2
node-undici Ubuntu:24.04:LTS
- Versiones
- 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
- 5.26.3+dfsg1+~cs23.10.12-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Ubuntu:26.10
- Versiones
- 7.18.2+dfsg+~cs3.2.0-1build1
- 7.24.6+dfsg+~cs3.2.0-3
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-undici Ubuntu:26.04:LTS
- Versiones
- 7.3.0+dfsg1+~cs24.12.11-2
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.18.2+dfsg+~cs3.2.0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada