CVE-2026-21441
CVE-2026-21441 · urllib3 vulnerable to decompression-bomb safeguard bypass when following HTTP redirects (streaming API)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.
urllib3 is an HTTP client library for Python. urllib3's streaming API is designed for the efficient handling of large HTTP responses by reading the content in chunks, rather than loading the entire response body into memory at once. urllib3 can perform decoding or decompression based on the HTTP `Content-Encoding` header (e.g., `gzip`, `deflate`, `br`, or `zstd`). When using the streaming API, the library decompresses only the necessary bytes, enabling partial content consumption. Starting in version 1.22 and prior to version 2.6.3, for HTTP redirect responses, the library would read the entire response body to drain the connection and decompress the content unnecessarily. This decompression occurred even before any read methods were called, and configured read limits did not restrict the amount of decompressed data. As a result, there was no safeguard against decompression bombs. A malicious server could exploit this to trigger excessive resource consumption on the client. Applications and libraries are affected when they stream content from untrusted sources by setting `preload_content=False` when they do not disable redirects. Users should upgrade to at least urllib3 v2.6.3, in which the library does not decode content of redirect responses when `preload_content=False`. If upgrading is not immediately possible, disable redirects by setting `redirect=False` for requests to untrusted source.
CVSS 8.9 · Alta · EPSS 2,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
urllib3
- Versiones
- >= 1.22, < 2.6.3: Afectada
Sin corrección publicada
python-urllib3 Debian:12
- Versiones
- 1.26.12-1
- 1.26.12-1+deb12u1
- 1.26.12-1+deb12u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.26.12-1+deb12u3
Actualiza a 1.26.12-1+deb12u3
python-urllib3 Debian:13
- Versiones
- 2.3.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.0-3+deb13u1
Actualiza a 2.3.0-3+deb13u1
python-urllib3 Debian:14
- Versiones
- 2.3.0-3
- 2.5.0-1
- 2.5.0-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.5.0-2
Actualiza a 2.5.0-2
urllib3 PyPI
- Versiones
- 1.22
- 1.23
- 1.24
- 1.24.1
- 1.24.2
- 1.24.3
- 1.25
- 1.25.1
- 1.25.10
- 1.25.11
- 1.25.2
- 1.25.3
- 1.25.4
- 1.25.5
- 1.25.6
- 1.25.7
- 1.25.8
- 1.25.9
- 1.26.0
- 1.26.1
- 1.26.10
- 1.26.11
- 1.26.12
- 1.26.13
- 1.26.14
- 1.26.15
- 1.26.16
- 1.26.17
- 1.26.18
- 1.26.19
- 1.26.2
- 1.26.20
- 1.26.3
- 1.26.4
- 1.26.5
- 1.26.6
- 1.26.7
- 1.26.8
- 1.26.9
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.0a3
- 2.0.0a4
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.1.0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.6.1
- 2.6.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.22, < 2.6.3
Actualiza a 2.6.3
python-urllib3 Ubuntu:Pro:18.04:LTS
- Versiones
- 1.21.1-1
- 1.22-1
- 1.22-1ubuntu0.18.04.1
- 1.22-1ubuntu0.18.04.2
- 1.22-1ubuntu0.18.04.2+esm1
- 1.22-1ubuntu0.18.04.2+esm2
- 1.22-1ubuntu0.18.04.2+esm3
- 1.22-1ubuntu0.18.04.2+esm4
- 1.22-1ubuntu0.18.04.2+esm5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-pip Ubuntu:Pro:18.04:LTS
- Versiones
- 9.0.1-2
- 9.0.1-2.3~ubuntu1
- 9.0.1-2.3~ubuntu1.18.04.1
- 9.0.1-2.3~ubuntu1.18.04.2
- 9.0.1-2.3~ubuntu1.18.04.3
- 9.0.1-2.3~ubuntu1.18.04.4
- 9.0.1-2.3~ubuntu1.18.04.5
- 9.0.1-2.3~ubuntu1.18.04.5+esm2
- 9.0.1-2.3~ubuntu1.18.04.5+esm3
- 9.0.1-2.3~ubuntu1.18.04.6
- 9.0.1-2.3~ubuntu1.18.04.6+esm1
- 9.0.1-2.3~ubuntu1.18.04.7
- 9.0.1-2.3~ubuntu1.18.04.7+esm1
- 9.0.1-2.3~ubuntu1.18.04.8
- 9.0.1-2.3~ubuntu1.18.04.8+esm1
- 9.0.1-2.3~ubuntu1.18.04.8+esm2
- 9.0.1-2.3~ubuntu1.18.04.8+esm4
- 9.0.1-2.3~ubuntu1.18.04.8+esm6
- 9.0.1-2.3~ubuntu1.18.04.8+esm7
- 9.0.1-2.3~ubuntu1.18.04.8+esm8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-urllib3 Ubuntu:Pro:20.04:LTS
- Versiones
- 1.24.1-1ubuntu1
- 1.24.1-1ubuntu2
- 1.25.8-1
- 1.25.8-2
- 1.25.8-2ubuntu0.1
- 1.25.8-2ubuntu0.2
- 1.25.8-2ubuntu0.3
- 1.25.8-2ubuntu0.4
- 1.25.8-2ubuntu0.4+esm1
- 1.25.8-2ubuntu0.4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.25.8-2ubuntu0.4+esm3
Actualiza a 1.25.8-2ubuntu0.4+esm3
python-urllib3 Ubuntu:22.04:LTS
- Versiones
- 1.26.5-1~exp1
- 1.26.5-1~exp1ubuntu0.1
- 1.26.5-1~exp1ubuntu0.2
- 1.26.5-1~exp1ubuntu0.3
- 1.26.5-1~exp1ubuntu0.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.26.5-1~exp1ubuntu0.5
Actualiza a 1.26.5-1~exp1ubuntu0.5
python-pip Ubuntu:Pro:22.04:LTS
- Versiones
- 20.3.4-4
- 21.3.1+dfsg-3
- 22.0.2+dfsg-1
- 22.0.2+dfsg-1ubuntu0.1
- 22.0.2+dfsg-1ubuntu0.2
- 22.0.2+dfsg-1ubuntu0.3
- 22.0.2+dfsg-1ubuntu0.4
- 22.0.2+dfsg-1ubuntu0.5
- 22.0.2+dfsg-1ubuntu0.6
- 22.0.2+dfsg-1ubuntu0.7
- 22.0.2+dfsg-1ubuntu0.7+esm1
- 22.0.2+dfsg-1ubuntu0.7+esm2
- 22.0.2+dfsg-1ubuntu0.7+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-urllib3 Ubuntu:24.04:LTS
- Versiones
- 1.26.16-1
- 1.26.18-1
- 2.0.7-1
- 2.0.7-1ubuntu0.1
- 2.0.7-1ubuntu0.2
- 2.0.7-1ubuntu0.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.7-1ubuntu0.4
Actualiza a 2.0.7-1ubuntu0.4
python-pip Ubuntu:Pro:24.04:LTS
- Versiones
- 23.2+dfsg-1
- 23.3+dfsg-1
- 24.0+dfsg-1
- 24.0+dfsg-1ubuntu1
- 24.0+dfsg-1ubuntu1.1
- 24.0+dfsg-1ubuntu1.2
- 24.0+dfsg-1ubuntu1.3
- 24.0+dfsg-1ubuntu1.3+esm1
- 24.0+dfsg-1ubuntu1.3+esm2
- 24.0+dfsg-1ubuntu1.3+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-pip Ubuntu:25.10
- Versiones
- 25.0+dfsg-1
- 25.1.1+dfsg-1
- 25.1.1+dfsg-1ubuntu1
- 25.1.1+dfsg-1ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-urllib3 Ubuntu:25.10
- Versiones
- 2.3.0-2
- 2.3.0-2ubuntu1
- 2.3.0-3
- 2.3.0-3ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.0-3ubuntu0.2
Actualiza a 2.3.0-3ubuntu0.2
python-pip Ubuntu:26.10
- Versiones
- 25.1.1+dfsg-1ubuntu2
- 26.1.2+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-pip Ubuntu:Pro:26.04:LTS
- Versiones
- 25.1.1+dfsg-1ubuntu2
- 25.1.1+dfsg-1ubuntu2+esm1
- 25.1.1+dfsg-1ubuntu2+esm2
- 25.1.1+dfsg-1ubuntu2+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/urllib3/urllib3/security/advisories/GHSA-38jv-5279-wg99
- https://github.com/urllib3/urllib3/commit/8864ac407bba8607950025e0979c4c69bc7abc7b
- https://lists.debian.org/debian-lts-announce/2026/01/msg00017.html
- https://access.redhat.com/security/cve/CVE-2026-21441
- https://bugzilla.redhat.com/show_bug.cgi?id=2427726
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-21441.json
- https://access.redhat.com/errata/RHSA-2026:2911
- https://access.redhat.com/errata/RHSA-2026:28043
- https://access.redhat.com/errata/RHSA-2026:1485
- https://access.redhat.com/errata/RHSA-2026:2765
- https://access.redhat.com/errata/RHSA-2026:2764
- https://access.redhat.com/errata/RHSA-2026:2760
- https://access.redhat.com/errata/RHSA-2026:1240
- https://access.redhat.com/errata/RHSA-2026:1224
- https://access.redhat.com/errata/RHSA-2026:1226
- https://access.redhat.com/errata/RHSA-2026:1803
- https://access.redhat.com/errata/RHSA-2026:1792
- https://access.redhat.com/errata/RHSA-2026:1791
- https://access.redhat.com/errata/RHSA-2026:1676
- https://access.redhat.com/errata/RHSA-2026:1734
- https://access.redhat.com/errata/RHSA-2026:1735
- https://access.redhat.com/errata/RHSA-2026:1546
- https://access.redhat.com/errata/RHSA-2026:1717
- https://nvd.nist.gov/vuln/detail/CVE-2026-21441