p PatchFirst

CVE-2026-23833

CVE-2026-23833 · ESPHome vulnerable to denial-of-service via out-of-bounds check bypass in the API component

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

ESPHome is a system to control microcontrollers remotely through Home Automation systems. In versions 2025.9.0 through 2025.12.6, an integer overflow in the API component's protobuf decoder allows denial-of-service attacks when API encryption is not used. The bounds check `ptr + field_length > end` in `components/api/proto.cpp` can overflow when a malicious client sends a large `field_length` value. This affects all ESPHome device platforms (ESP32, ESP8266, RP2040, LibreTiny). The overflow bypasses the out-of-bounds check, causing the device to read invalid memory and crash. When using the plaintext API protocol, this attack can be performed without authentication. When noise encryption is enabled, knowledge of the encryption key is required. Users should upgrade to ESPHome 2025.12.7 or later to receive a patch, enable API encryption with a unique key per device, and follow the Security Best Practices.

CVSS 1.7 · Baja · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • esphome

    Versiones
    • >= 2025.9.0, < 2025.12.7: Afectada

    Sin corrección publicada

  • esphome PyPI

    Versiones
    • 2025.10.0
    • 2025.10.0b1
    • 2025.10.0b2
    • 2025.10.0b3
    • 2025.10.0b4
    • 2025.10.1
    • 2025.10.2
    • 2025.10.3
    • 2025.10.4
    • 2025.10.5
    • 2025.11.0
    • 2025.11.0b1
    • 2025.11.0b2
    • 2025.11.0b3
    • 2025.11.0b4
    • 2025.11.0b5
    • 2025.11.1
    • 2025.11.2
    • 2025.11.3
    • 2025.11.4
    • 2025.11.5
    • 2025.12.0
    • 2025.12.0b1
    • 2025.12.0b2
    • 2025.12.0b3
    • 2025.12.0b4
    • 2025.12.0b5
    • 2025.12.1
    • 2025.12.2
    • 2025.12.3
    • 2025.12.4
    • 2025.12.5
    • 2025.12.6
    • 2025.9.0
    • 2025.9.1
    • 2025.9.2
    • 2025.9.3
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2025.9.0, < 2025.12.7

    Actualiza a 2025.12.7

Fuentes originales

Comprueba tu servidor →