CVE-2026-24486
CVE-2026-24486 · Python-Multipart has Arbitrary File Write via Non-Default Configuration
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Python-Multipart is a streaming multipart parser for Python. Prior to version 0.0.22, a Path Traversal vulnerability exists when using non-default configuration options `UPLOAD_DIR` and `UPLOAD_KEEP_FILENAME=True`. An attacker can write uploaded files to arbitrary locations on the filesystem by crafting a malicious filename. Users should upgrade to version 0.0.22 to receive a patch or, as a workaround, avoid using `UPLOAD_KEEP_FILENAME=True` in project configurations.
CVSS 8.6 · Alta · EPSS 2,2% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
python-multipart
- Versiones
- < 0.0.22: Afectada
Sin corrección publicada
python-multipart Debian:12
- Versiones
- 0.0.17-1
- 0.0.17-2
- 0.0.17-3
- 0.0.17-4
- 0.0.17-5
- 0.0.20-1
- 0.0.20-1.1
- 0.0.20-1.1~deb13u1
- 0.0.22-1
- 0.0.26-1
- 0.0.32-1
- 0.0.5-3
- 0.0.6-1
- 0.0.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-multipart Debian:13
- Versiones
- 0.0.20-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.0.20-1.1~deb13u1
Actualiza a 0.0.20-1.1~deb13u1
python-multipart Debian:14
- Versiones
- 0.0.20-1
- 0.0.20-1.1~deb13u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.0.20-1.1
Actualiza a 0.0.20-1.1
python-multipart PyPI
- Versiones
- 0.0.1
- 0.0.10
- 0.0.11
- 0.0.12
- 0.0.13
- 0.0.14
- 0.0.15
- 0.0.16
- 0.0.17
- 0.0.18
- 0.0.19
- 0.0.2
- 0.0.20
- 0.0.21
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- 0.0.7
- 0.0.8
- 0.0.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.0.22
Actualiza a 0.0.22
python-multipart Ubuntu:Pro:22.04:LTS
- Versiones
- 0.0.5-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.0.5-2ubuntu0.1~esm1
Actualiza a 0.0.5-2ubuntu0.1~esm1
python-multipart Ubuntu:Pro:24.04:LTS
- Versiones
- 0.0.5-3
- 0.0.6-1
- 0.0.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.0.9-1ubuntu0.1~esm1
Actualiza a 0.0.9-1ubuntu0.1~esm1
python-multipart Ubuntu:25.10
- Versiones
- 0.0.20-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-multipart Ubuntu:26.10
- Versiones
- 0.0.20-1.1
- 0.0.26-1
- 0.0.32-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-multipart Ubuntu:26.04:LTS
- Versiones
- 0.0.20-1
- 0.0.20-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/Kludex/python-multipart/security/advisories/GHSA-wp53-j4wj-2cfg
- https://github.com/Kludex/python-multipart/commit/9433f4bbc9652bdde82bbe380984e32f8cfc89c4
- https://github.com/Kludex/python-multipart/releases/tag/0.0.22
- https://access.redhat.com/security/cve/CVE-2026-24486
- https://bugzilla.redhat.com/show_bug.cgi?id=2433132
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24486.json
- https://access.redhat.com/errata/RHSA-2026:3461
- https://access.redhat.com/errata/RHSA-2026:3462
- https://access.redhat.com/errata/RHSA-2026:3960
- https://access.redhat.com/errata/RHSA-2026:10184
- https://access.redhat.com/errata/RHSA-2026:42644
- https://access.redhat.com/errata/RHSA-2026:3782
- https://access.redhat.com/errata/RHSA-2026:19712
- https://access.redhat.com/errata/RHSA-2026:3713
- https://access.redhat.com/errata/RHSA-2026:44696
- https://access.redhat.com/errata/RHSA-2026:1504
- https://access.redhat.com/errata/RHSA-2026:51357
- https://nvd.nist.gov/vuln/detail/CVE-2026-24486