CVE-2026-24733
CVE-2026-24733 · Apache Tomcat: Security constraint bypass with HTTP/0.9
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.
CVSS 6.5 · Media · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
apache tomcat
- Versiones
- ≥ 11.0.0-M1, ≤ 11.0.14: Afectada (semver)
- ≥ 10.1.0-M1, ≤ 10.1.49: Afectada (semver)
- ≥ 9.0.0.M1, ≤ 9.0.112: Afectada (semver)
- ≥ 0, ≤ 8.5.100: Afectada (semver)
Sin corrección publicada
tomcat10 Debian:12
- Versiones
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.34-0+deb12u1
- 10.1.34-0+deb12u2
- 10.1.34-1
- 10.1.35-1
- 10.1.40-1
- 10.1.40-1~bpo12+1
- 10.1.46-1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.52-1~deb12u1
Actualiza a 10.1.52-1~deb12u1
tomcat10 Debian:13
- Versiones
- 10.1.40-1
- 10.1.46-1
- 10.1.52-1~deb12u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.52-1~deb13u1
Actualiza a 10.1.52-1~deb13u1
tomcat10 Debian:14
- Versiones
- 10.1.40-1
- 10.1.46-1
- 10.1.52-1~deb12u1
- 10.1.52-1~deb13u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.52-1
Actualiza a 10.1.52-1
tomcat11 Debian:13
- Versiones
- 11.0.11-1
- 11.0.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 11.0.15-1~deb13u1
Actualiza a 11.0.15-1~deb13u1
tomcat11 Debian:14
- Versiones
- 11.0.11-1
- 11.0.15-1~deb13u1
- 11.0.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 11.0.15-1
Actualiza a 11.0.15-1
tomcat9 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat6 Ubuntu:Pro:14.04:LTS
- Versiones
- 6.0.37-1
- 6.0.39-1
- 6.0.39-1ubuntu0.1
- 6.0.39-1ubuntu0.1+esm1
- 6.0.39-1ubuntu0.1+esm2
- 6.0.39-1ubuntu0.1+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:Pro:18.04:LTS
- Versiones
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- 9.0.16-3ubuntu0.18.04.2+esm7
- 9.0.16-3ubuntu0.18.04.2+esm8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:Pro:20.04:LTS
- Versiones
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- 9.0.31-1ubuntu0.9+esm2
- 9.0.31-1ubuntu0.9+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:Pro:22.04:LTS
- Versiones
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- 9.0.58-1ubuntu0.2+esm3
- 9.0.58-1ubuntu0.2+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat10 Ubuntu:24.04:LTS
- Versiones
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- 10.1.16-1ubuntu0.1~esm2
- 10.1.16-1ubuntu0.1~esm3
- 10.1.16-1ubuntu0.1~esm4
- 10.1.55-1ubuntu2~24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:24.04:LTS
- Versiones
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- 9.0.70-2ubuntu0.1+esm2
- 9.0.70-2ubuntu0.1+esm3
- 9.0.118-1~24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat10 Ubuntu:25.10
- Versiones
- 10.1.35-1
- 10.1.40-1
- 10.1.40-1ubuntu1
- 10.1.40-1ubuntu1.25.10.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat11 Ubuntu:25.10
- Versiones
- 11.0.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:25.10
- Versiones
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- 9.0.70-2ubuntu3
- 9.0.95-1ubuntu1
- 9.0.95-1ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat10 Ubuntu:26.04:LTS
- Versiones
- 10.1.40-1ubuntu1
- 10.1.40-1ubuntu1.26.04.1
- 10.1.55-1ubuntu2~26.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada