CVE-2026-25528
CVE-2026-25528 · LangSmith Client SDK Affected by Server-Side Request Forgery via Tracing Header Injection
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
LangSmith Client SDKs provide SDK's for interacting with the LangSmith platform. The LangSmith SDK's distributed tracing feature is vulnerable to Server-Side Request Forgery via malicious HTTP headers. An attacker can inject arbitrary api_url values through the baggage header, causing the SDK to exfiltrate sensitive trace data to attacker-controlled endpoints. When using distributed tracing, the SDK parses incoming HTTP headers via RunTree.from_headers() in Python or RunTree.fromHeaders() in Typescript. The baggage header can contain replica configurations including api_url and api_key fields. Prior to the fix, these attacker-controlled values were accepted without validation. When a traced operation completes, the SDK's post() and patch() methods send run data to all configured replica URLs, including any injected by an attacker. This vulnerability is fixed in version 0.6.3 of the Python SDK and 0.4.6 of the JavaScript SDK.
CVSS 5.8 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python · node
Productos y versiones afectados
langsmith-sdk
- Versiones
- >= 0.4.10, <0.6.3: Afectada
Sin corrección publicada
langsmith PyPI
- Versiones
- 0.4.10
- 0.4.11
- 0.4.12
- 0.4.13
- 0.4.14
- 0.4.15
- 0.4.16
- 0.4.17
- 0.4.18
- 0.4.19
- 0.4.20
- 0.4.21
- 0.4.22
- 0.4.23
- 0.4.24
- 0.4.25
- 0.4.26
- 0.4.27
- 0.4.28
- 0.4.29
- 0.4.30
- 0.4.31
- 0.4.32
- 0.4.32rc0
- 0.4.33
- 0.4.34
- 0.4.35
- 0.4.35rc1
- 0.4.36
- 0.4.37
- 0.4.38
- 0.4.39
- 0.4.39rc0
- 0.4.39rc1
- 0.4.40
- 0.4.41
- 0.4.42
- 0.4.42rc0
- 0.4.43
- 0.4.43rc0
- 0.4.44
- 0.4.45
- 0.4.46
- 0.4.47
- 0.4.48
- 0.4.49
- 0.4.50
- 0.4.51
- 0.4.52
- 0.4.53
- 0.4.54
- 0.4.54rc0
- 0.4.55
- 0.4.56
- 0.4.57
- 0.4.58
- 0.4.59
- 0.4.60
- 0.5.0
- 0.5.1
- 0.5.2
- 0.6.0
- 0.6.0rc0
- 0.6.1
- 0.6.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.4.10, < 0.6.3
Actualiza a 0.6.3
langsmith npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.3.41, < 0.4.6
Actualiza a 0.4.6