p PatchFirst

CVE-2026-25646

CVE-2026-25646 · LIBPNG has a heap buffer overflow in png_set_quantize

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to 1.6.55, an out-of-bounds read vulnerability exists in the png_set_quantize() API function. When the function is called with no histogram and the number of colors in the palette is more than twice the maximum supported by the user's display, certain palettes will cause the function to enter into an infinite loop that reads past the end of an internal heap-allocated buffer. The images that trigger this vulnerability are valid per the PNG specification. This vulnerability is fixed in 1.6.55.

CVSS 8.3 · Alta · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • libpng

    Versiones
    • < 1.6.55: Afectada

    Sin corrección publicada

  • libpng1.6 Debian:12

    Versiones
    • 1.6.39-2
    • 1.6.39-2+deb12u1
    • 1.6.39-2+deb12u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.39-2+deb12u3

    Actualiza a 1.6.39-2+deb12u3

  • libpng1.6 Debian:13

    Versiones
    • 1.6.48-1
    • 1.6.48-1+deb13u1
    • 1.6.48-1+deb13u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.48-1+deb13u3

    Actualiza a 1.6.48-1+deb13u3

  • libpng1.6 Debian:14

    Versiones
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1
    • 1.6.50-1~exp1
    • 1.6.51-1
    • 1.6.52-1
    • 1.6.53-1
    • 1.6.54-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.55-1

    Actualiza a 1.6.55-1

  • libpng Ubuntu:Pro:14.04:LTS

    Versiones
    • 1.2.49-4ubuntu1
    • 1.2.49-5ubuntu1
    • 1.2.50-1ubuntu1
    • 1.2.50-1ubuntu2
    • 1.2.50-1ubuntu2.14.04.1
    • 1.2.50-1ubuntu2.14.04.2
    • 1.2.50-1ubuntu2.14.04.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.2.50-1ubuntu2.14.04.3+esm1

    Actualiza a 1.2.50-1ubuntu2.14.04.3+esm1

  • libpng Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.2.51-0ubuntu3
    • 1.2.54-1
    • 1.2.54-1ubuntu1
    • 1.2.54-1ubuntu1.1
    • 1.2.54-1ubuntu1.1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.2.54-1ubuntu1.1+esm2

    Actualiza a 1.2.54-1ubuntu1.1+esm2

  • libpng1.6 Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.6.20-2
    • 1.6.20-2ubuntu0.1~esm1
    • 1.6.20-2ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm3

    Actualiza a 1.6.20-2ubuntu0.1~esm3

  • libpng1.6 Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.6.34-1
    • 1.6.34-1ubuntu0.18.04.1
    • 1.6.34-1ubuntu0.18.04.2
    • 1.6.34-1ubuntu0.18.04.2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm2

    Actualiza a 1.6.34-1ubuntu0.18.04.2+esm2

  • libpng1.6 Ubuntu:Pro:20.04:LTS

    Versiones
    • 1.6.37-1
    • 1.6.37-2
    • 1.6.37-2ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm2

    Actualiza a 1.6.37-2ubuntu0.1~esm2

  • libpng1.6 Ubuntu:22.04:LTS

    Versiones
    • 1.6.37-3build4
    • 1.6.37-3build5
    • 1.6.37-3ubuntu0.1
    • 1.6.37-3ubuntu0.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.37-3ubuntu0.4

    Actualiza a 1.6.37-3ubuntu0.4

  • libpng1.6 Ubuntu:24.04:LTS

    Versiones
    • 1.6.40-1
    • 1.6.40-2
    • 1.6.40-3
    • 1.6.42-1
    • 1.6.43-1
    • 1.6.43-3
    • 1.6.43-5build1
    • 1.6.43-5ubuntu0.1
    • 1.6.43-5ubuntu0.3
    • 1.6.43-5ubuntu0.4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.43-5ubuntu0.5

    Actualiza a 1.6.43-5ubuntu0.5

  • libpng1.6 Ubuntu:25.10

    Versiones
    • 1.6.47-1.1
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1~exp1
    • 1.6.50-1
    • 1.6.50-1ubuntu0.1
    • 1.6.50-1ubuntu0.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.50-1ubuntu0.4

    Actualiza a 1.6.50-1ubuntu0.4

  • libpng1.6 Ubuntu:26.04:LTS

    Versiones
    • 1.6.50-1
    • 1.6.51-1
    • 1.6.53-1
    • 1.6.54-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.55-1

    Actualiza a 1.6.55-1

Fuentes originales

Comprueba tu servidor →