p PatchFirst

CVE-2026-25892

CVE-2026-25892 · Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Adminer is open-source database management software. Adminer v5.4.1 and earlier has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, openssl_verify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Upgrade to Adminer 5.4.2.

CVSS 7.5 · Alta · EPSS 1,7% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · php

Productos y versiones afectados

  • adminer

    Versiones
    • >= 4.6.2, < 5.4.2: Afectada

    Sin corrección publicada

  • vrana/adminer Packagist

    Versiones
    • v4.10
    • v4.11
    • v4.12
    • v4.13
    • v4.14
    • v4.16.0
    • v4.17.0
    • v4.17.1
    • v4.6.2
    • v4.6.3
    • v4.7.0
    • v4.7.1
    • v4.7.2
    • v4.7.3
    • v4.7.4
    • v4.7.5
    • v4.7.6
    • v4.7.7
    • v4.7.8
    • v4.7.9
    • v4.8.0
    • v4.8.1
    • v4.8.2
    • v4.9
    • v4.9.1
    • v4.9.2
    • v4.9.3
    • v4.9.4
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    • v5.1.0
    • v5.1.1
    • v5.2.0
    • v5.2.1
    • v5.3.0
    • v5.4.0
    • v5.4.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 4.6.2, < 5.4.2

    Actualiza a 5.4.2

  • adminer Ubuntu:Pro:16.04:LTS

    Versiones
    • 4.2.1-1
    • 4.2.1-1ubuntu1
    • 4.2.1-1ubuntu1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:Pro:18.04:LTS

    Versiones
    • 4.3.1-2
    • 4.5.0-1
    • 4.6.1-1
    • 4.6.2-1
    • 4.6.2-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:Pro:20.04:LTS

    Versiones
    • 4.7.2-1
    • 4.7.4-1
    • 4.7.5-1
    • 4.7.6-1
    • 4.7.6-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:22.04:LTS

    Versiones
    • 4.7.9-2
    • 4.8.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:24.04:LTS

    Versiones
    • 4.8.1-1
    • 4.8.1-1ubuntu1
    • 4.8.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:25.10

    Versiones
    • 4.8.1-4
    • 5.2.1+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:26.10

    Versiones
    • 5.4.1+dfsg-1
    • 5.4.2+dfsg-1
    • 5.4.4+dfsg-1
    • 6.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • adminer Ubuntu:26.04:LTS

    Versiones
    • 5.2.1+dfsg-1
    • 5.3.0+dfsg-1
    • 5.4.0+dfsg-1
    • 5.4.1+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →