CVE-2026-25918
CVE-2026-25918 · unity-cli Exposes Plaintext Credentials in Debug Logs (sign-package command)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
unity-cli is a command line utility for the Unity Game Engine. Prior to 1.8.2 , the sign-package command in @rage-against-the-pixel/unity-cli logs sensitive credentials in plaintext when the --verbose flag is used. Command-line arguments including --email and --password are output via JSON.stringify without sanitization, exposing secrets to shell history, CI/CD logs, and log aggregation systems. This vulnerability is fixed in 1.8.2.
CVSS 5.9 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
unity-cli
- Versiones
- < 1.8.2: Afectada
Sin corrección publicada
@rage-against-the-pixel/unity-cli npm
- Intervalos de versiones afectados
- SEMVER: < 1.8.2
Actualiza a 1.8.2
unity Ubuntu:16.04:LTS
- Versiones
- 7.3.2+15.10.20151016-0ubuntu1
- 7.4.0+16.04.20151102-0ubuntu1
- 7.4.0+16.04.20151102-0ubuntu2
- 7.4.0+16.04.20151211-0ubuntu1
- 7.4.0+16.04.20151211-0ubuntu2
- 7.4.0+16.04.20151218-0ubuntu1
- 7.4.0+16.04.20151218-0ubuntu2
- 7.4.0+16.04.20160209.3-0ubuntu1
- 7.4.0+16.04.20160223.1-0ubuntu1
- 7.4.0+16.04.20160310-0ubuntu1
- 7.4.0+16.04.20160318-0ubuntu1
- 7.4.0+16.04.20160321-0ubuntu1
- 7.4.0+16.04.20160322-0ubuntu1
- 7.4.0+16.04.20160401.1-0ubuntu1
- 7.4.0+16.04.20160415-0ubuntu1
- 7.4.0+16.04.20160526.1-0ubuntu1
- 7.4.0+16.04.20160715-0ubuntu1
- 7.4.0+16.04.20160801.2-0ubuntu1
- 7.4.0+16.04.20160906-0ubuntu1
- 7.4.5+16.04.20171201.3
- 7.4.5+16.04.20180221-0ubuntu1
- 7.4.5+16.04.20190312-0ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
unity Ubuntu:18.04:LTS
- Versiones
- 7.5.0+17.10.20171010-0ubuntu1
- 7.5.0+18.04.20171116-0ubuntu1
- 7.5.0+18.04.20180221.1-0ubuntu1
- 7.5.0+18.04.20180321-0ubuntu1
- 7.5.0+18.04.20180404-0ubuntu1
- 7.5.0+18.04.20180404-0ubuntu2
- 7.5.0+18.04.20180409-0ubuntu1
- 7.5.0+18.04.20180413-0ubuntu1
- 7.5.0+18.04.20190304-0ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
unity Ubuntu:20.04:LTS
- Versiones
- 7.5.0+19.10.20190924-0ubuntu1
- 7.5.0+20.04.20200211-0ubuntu1
- 7.5.0+20.04.20200211-0ubuntu2
- 7.5.0+20.04.20200312-0ubuntu1
- 7.5.1+20.04.20211026.1-0ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
unity Ubuntu:22.04:LTS
- Versiones
- 7.5.1+21.10.20210601.1-0ubuntu1
- 7.5.1+22.04.20211026.2-0ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
unity Ubuntu:24.04:LTS
- Versiones
- 7.7.0+23.04.20230222.2-0ubuntu2
- 7.7.0+23.04.20230222.2-0ubuntu4
- 7.7.0+23.04.20230222.2-0ubuntu6
- 7.7.0+23.04.20230222.2-0ubuntu7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
unity Ubuntu:25.10
- Versiones
- 7.7.0+23.04.20230222.2-0ubuntu8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
unity Ubuntu:26.10
- Versiones
- 7.7.1+26.04.20260306-0ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
unity Ubuntu:26.04:LTS
- Versiones
- 7.7.0+23.04.20230222.2-0ubuntu8
- 7.7.1+26.04.20260306-0ubuntu1
- 7.7.1+26.04.20260306-0ubuntu2
- 7.7.1+26.04.20260306-0ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada