CVE-2026-2652
CVE-2026-2652 · Authentication Bypass in mlflow/mlflow
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A vulnerability in mlflow/mlflow versions 3.9.0 and earlier allows unauthenticated access to certain FastAPI routes when the server is started with authentication enabled (`--app-name basic-auth`) and served via uvicorn (ASGI). The FastAPI permission middleware only enforces authentication on `/gateway/` routes, leaving other routes such as the Job API (`/ajax-api/3.0/jobs/*`) and the OpenTelemetry trace ingestion API (`/v1/traces`) unprotected. This allows unauthenticated remote attackers to submit jobs, read job results, cancel running jobs, and inject arbitrary trace data into experiments. The issue arises from an architectural mismatch between Flask and FastAPI authentication mechanisms, where the `_find_fastapi_validator()` function fails to handle non-`/gateway/` paths, resulting in a complete authentication bypass. This vulnerability is fixed in version 3.10.0.
CVSS 8.6 · Alta · EPSS 20,8% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
mlflow/mlflow
- Versiones
- ≥ unspecified, < 3.10.0: Afectada (custom)
Actualiza a 3.10.0
mlflow PyPI
- Versiones
- 0.0.1
- 0.1.0
- 0.2.0
- 0.2.1
- 0.3.0
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.1
- 0.5.2
- 0.6.0
- 0.7.0
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.0
- 0.9.0.1
- 0.9.1
- 1.0.0
- 1.1.0
- 1.1.1.dev0
- 1.10.0
- 1.11.0
- 1.12.0
- 1.12.1
- 1.13
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.17.0
- 1.18.0
- 1.19.0
- 1.2.0
- 1.20.0
- 1.20.1
- 1.20.2
- 1.21.0
- 1.22.0
- 1.23.0
- 1.23.1
- 1.24.0
- 1.25.0
- 1.25.1
- 1.26.0
- 1.26.1
- 1.27.0
- 1.28.0
- 1.29.0
- 1.3.0
- 1.30.0
- 1.30.1
- 1.4.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.7.1
- 1.7.2
- 1.8.0
- 1.9.0
- 1.9.1
- 2.0.0
- 2.0.0rc0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.10.0
- 2.10.1
- 2.10.2
- 2.11.0
- 2.11.1
- 2.11.2
- 2.11.3
- 2.11.4
- 2.12.0
- 2.12.1
- 2.12.2
- 2.13.0
- 2.13.1
- 2.13.2
- 2.14.0
- 2.14.0rc0
- 2.14.1
- 2.14.2
- 2.14.2.dev0
- 2.14.3
- 2.15.0
- 2.15.0rc0
- 2.15.1
- 2.16.0
- 2.16.1
- 2.16.2
- 2.17.0
- 2.17.0rc0
- 2.17.1
- 2.17.2
- 2.18.0
- 2.18.0rc0
- 2.19.0
- 2.19.0rc0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.20.0
- 2.20.0rc0
- 2.20.1
- 2.20.2
- 2.20.3
- 2.20.4
- 2.21.0
- 2.21.0rc0
- 2.21.1
- 2.21.2
- 2.21.3
- 2.22.0
- 2.22.0rc0
- 2.22.1
- 2.22.2
- 2.22.3
- 2.22.4
- 2.22.5
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.0
- 2.6.0
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.9.0
- 2.9.1
- 2.9.2
- 3.0.0
- 3.0.0rc0
- 3.0.0rc1
- 3.0.0rc2
- 3.0.0rc3
- 3.0.1
- 3.1.0
- 3.1.0rc0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.10.0
- 3.10.0rc0
- 3.10.1
- 3.11.0rc0
- 3.11.0rc1
- 3.2.0
- 3.2.0rc0
- 3.3.0
- 3.3.0rc0
- 3.3.1
- 3.3.2
- 3.4.0
- 3.4.0rc0
- 3.5.0
- 3.5.0rc0
- 3.5.1
- 3.6.0
- 3.6.0rc0
- 3.7.0
- 3.7.0rc0
- 3.8.0
- 3.8.0rc0
- 3.8.1
- 3.9.0
- 3.9.0rc0
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.11.0
Actualiza a 3.11.0
mlflow PyPI
- Versiones
- 0.0.1
- 0.1.0
- 0.2.0
- 0.2.1
- 0.3.0
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.1
- 0.5.2
- 0.6.0
- 0.7.0
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.0
- 0.9.0.1
- 0.9.1
- 1.0.0
- 1.1.0
- 1.1.1.dev0
- 1.10.0
- 1.11.0
- 1.12.0
- 1.12.1
- 1.13
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.17.0
- 1.18.0
- 1.19.0
- 1.2.0
- 1.20.0
- 1.20.1
- 1.20.2
- 1.21.0
- 1.22.0
- 1.23.0
- 1.23.1
- 1.24.0
- 1.25.0
- 1.25.1
- 1.26.0
- 1.26.1
- 1.27.0
- 1.28.0
- 1.29.0
- 1.3.0
- 1.30.0
- 1.30.1
- 1.4.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.7.1
- 1.7.2
- 1.8.0
- 1.9.0
- 1.9.1
- 2.0.0
- 2.0.0rc0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.10.0
- 2.10.1
- 2.10.2
- 2.11.0
- 2.11.1
- 2.11.2
- 2.11.3
- 2.11.4
- 2.12.0
- 2.12.1
- 2.12.2
- 2.13.0
- 2.13.1
- 2.13.2
- 2.14.0
- 2.14.0rc0
- 2.14.1
- 2.14.2
- 2.14.2.dev0
- 2.14.3
- 2.15.0
- 2.15.0rc0
- 2.15.1
- 2.16.0
- 2.16.1
- 2.16.2
- 2.17.0
- 2.17.0rc0
- 2.17.1
- 2.17.2
- 2.18.0
- 2.18.0rc0
- 2.19.0
- 2.19.0rc0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.20.0
- 2.20.0rc0
- 2.20.1
- 2.20.2
- 2.20.3
- 2.20.4
- 2.21.0
- 2.21.0rc0
- 2.21.1
- 2.21.2
- 2.21.3
- 2.22.0
- 2.22.0rc0
- 2.22.1
- 2.22.2
- 2.22.3
- 2.22.4
- 2.22.5
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.0
- 2.6.0
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.9.0
- 2.9.1
- 2.9.2
- 3.0.0
- 3.0.0rc0
- 3.0.0rc1
- 3.0.0rc2
- 3.0.0rc3
- 3.0.1
- 3.1.0
- 3.1.0rc0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.10.0rc0
- 3.2.0
- 3.2.0rc0
- 3.3.0
- 3.3.0rc0
- 3.3.1
- 3.3.2
- 3.4.0
- 3.4.0rc0
- 3.5.0
- 3.5.0rc0
- 3.5.1
- 3.6.0
- 3.6.0rc0
- 3.7.0
- 3.7.0rc0
- 3.8.0
- 3.8.0rc0
- 3.8.1
- 3.9.0
- 3.9.0rc0
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.10.0
Actualiza a 3.10.0