CVE-2026-27489
CVE-2026-27489 · ONNX: Path Traversal via Symlink
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to version 1.21.0, a path traversal vulnerability via symlink allows to read arbitrary files outside model or user-provided directory. This issue has been patched in version 1.21.0.
CVSS 8.7 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
onnx
- Versiones
- < 1.21.0: Afectada
Sin corrección publicada
onnx Debian:12
- Versiones
- 1.12.0-2
- 1.13.1-1
- 1.13.1-2
- 1.13.1-3
- 1.14.1-1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1~exp1
- 1.16.1-1
- 1.16.2-1
- 1.17.0-1
- 1.17.0-2
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Debian:13
- Versiones
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Debian:14
- Versiones
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx PyPI
- Versiones
- 0.1
- 0.2
- 0.2.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.16.1
- 1.16.2
- 1.17.0
- 1.18.0
- 1.19.0
- 1.19.1
- 1.19.1rc1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.1
- 1.20.1rc1
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.0rc4
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.21.0
Actualiza a 1.21.0
onnx Ubuntu:22.04:LTS
- Versiones
- 1.7.0+dfsg-3build1
- 1.7.0+dfsg-3build2
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:Pro:24.04:LTS
- Versiones
- 1.13.1-3
- 1.13.1-3build1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1build1
- 1.14.1-2.1build2
- 1.14.1-2.1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:25.10
- Versiones
- 1.17.0-3build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:26.10
- Versiones
- 1.20.0-1
- 1.20.0-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:26.04:LTS
- Versiones
- 1.17.0-3build1
- 1.20.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/onnx/onnx/security/advisories/GHSA-3r9x-f23j-gc73
- https://github.com/onnx/onnx/commit/4755f8053928dce18a61db8fec71b69c74f786cb
- https://access.redhat.com/security/cve/CVE-2026-27489
- https://bugzilla.redhat.com/show_bug.cgi?id=2453929
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-27489.json
- https://access.redhat.com/errata/RHSA-2026:24977
- https://nvd.nist.gov/vuln/detail/CVE-2026-27489