CVE-2026-29786
CVE-2026-29786 · node-tar: Hardlink Path Traversal via Drive-Relative Linkpath
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
node-tar is a full-featured Tar for Node.js. Prior to version 7.5.10, tar can be tricked into creating a hardlink that points outside the extraction directory by using a drive-relative link target such as C:../target.txt, which enables file overwrite outside cwd during normal tar.x() extraction. This issue has been patched in version 7.5.10.
CVSS 8.2 · Alta · EPSS 0,5% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
node-tar
- Versiones
- < 7.5.10: Afectada
Sin corrección publicada
node-tar Debian:12
- Versiones
- 6.1.13+~cs7.0.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.1.13+~cs7.0.5-1+deb12u1
Actualiza a 6.1.13+~cs7.0.5-1+deb12u1
node-tar Debian:13
- Versiones
- 6.2.1+~cs7.0.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.2.1+~cs7.0.8-1+deb13u1
Actualiza a 6.2.1+~cs7.0.8-1+deb13u1
node-tar Debian:14
- Versiones
- 6.2.1+ds1+~cs6.1.13-1
- 6.2.1+ds1+~cs6.1.13-2
- 6.2.1+ds1+~cs6.1.13-3
- 6.2.1+ds1+~cs6.1.13-4
- 6.2.1+ds1+~cs6.1.13-5
- 6.2.1+ds1+~cs6.1.13-6
- 6.2.1+ds1+~cs6.1.13-7
- 6.2.1+~cs7.0.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.2.1+ds1+~cs6.1.13-8
Actualiza a 6.2.1+ds1+~cs6.1.13-8
tar npm
- Intervalos de versiones afectados
- SEMVER: < 7.5.10
Actualiza a 7.5.10
node-tar Ubuntu:Pro:14.04:LTS
- Versiones
- 0.1.18-1
- 0.1.18-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-tar Ubuntu:Pro:16.04:LTS
- Versiones
- 1.0.3-2
- 1.0.3-2ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-tar Ubuntu:18.04:LTS
- Versiones
- 2.2.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-tar Ubuntu:Pro:20.04:LTS
- Versiones
- 4.4.10+ds1-2
- 4.4.10+ds1-2ubuntu1
- 4.4.10+ds1-2ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-tar Ubuntu:22.04:LTS
- Versiones
- 6.1.7+~cs11.3.10-1
- 6.1.11+~cs11.3.10-1
- 6.1.11+ds1+~cs6.0.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-tar Ubuntu:24.04:LTS
- Versiones
- 6.1.13+~cs7.0.5-1
- 6.1.13+~cs7.0.5-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-tar Ubuntu:25.10
- Versiones
- 6.2.1+~cs7.0.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-tar Ubuntu:26.04:LTS
- Versiones
- 6.2.1+~cs7.0.8-1
- 6.2.1+ds1+~cs6.1.13-6
- 6.2.1+ds1+~cs6.1.13-7
- 6.2.1+ds1+~cs6.1.13-10
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/isaacs/node-tar/security/advisories/GHSA-qffp-2rhf-9h96
- https://github.com/isaacs/node-tar/commit/7bc755dd85e623c0279e08eb3784909e6d7e4b9f
- https://access.redhat.com/security/cve/CVE-2026-29786
- https://bugzilla.redhat.com/show_bug.cgi?id=2445476
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-29786.json
- https://nvd.nist.gov/vuln/detail/CVE-2026-29786