CVE-2026-29790
CVE-2026-29790 · dbt-common: commonprefix() doesn't protect against path traversal
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
dbt-common is the shared common utilities for dbt-core and adapter implementations use. Prior to versions 1.34.2 and 1.37.3, a path traversal vulnerability exists in dbt-common's safe_extract() function used when extracting tarball archives. The function uses os.path.commonprefix() to validate that extracted files remain within the intended destination directory. However, commonprefix() compares paths character-by-character rather than by path components, allowing a malicious tarball to write files to sibling directories with matching name prefixes. This issue has been patched in versions 1.34.2 and 1.37.3.
CVSS 2.0 · Baja · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
dbt-common
- Versiones
- < 1.37.3: Afectada
- < 1.34.2: Afectada
Sin corrección publicada
dbt-common PyPI
- Versiones
- 0.1.0
- 0.1.0a1
- 0.1.1
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 1.0.0
- 1.0.0b1
- 1.0.0b2
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.1.0
- 1.10.0
- 1.11.0
- 1.12.0
- 1.13.0
- 1.14.0
- 1.15.0
- 1.16.0
- 1.17.0
- 1.18
- 1.19
- 1.2.0
- 1.20
- 1.21.0
- 1.22.0
- 1.23.0
- 1.24.0
- 1.25.0
- 1.25.1
- 1.26.0
- 1.27.0
- 1.27.1
- 1.28.0
- 1.29.0
- 1.3.0
- 1.30.0
- 1.31.0
- 1.32.0
- 1.33.0
- 1.34.0
- 1.34.1
- 1.4.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.34.2
Actualiza a 1.34.2
dbt-common PyPI
- Versiones
- 1.35.0
- 1.36.0
- 1.37.0
- 1.37.1
- 1.37.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.35.0, < 1.37.3
Actualiza a 1.37.3
dbt-common PyPI
- Versiones
- 0.1.0
- 0.1.0a1
- 0.1.1
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 1.0.0
- 1.0.0b1
- 1.0.0b2
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.1.0
- 1.10.0
- 1.11.0
- 1.12.0
- 1.13.0
- 1.14.0
- 1.15.0
- 1.16.0
- 1.17.0
- 1.18
- 1.19
- 1.2.0
- 1.20
- 1.21.0
- 1.22.0
- 1.23.0
- 1.24.0
- 1.25.0
- 1.25.1
- 1.26.0
- 1.27.0
- 1.27.1
- 1.28.0
- 1.29.0
- 1.3.0
- 1.30.0
- 1.31.0
- 1.32.0
- 1.33.0
- 1.34.0
- 1.34.1
- 1.35.0
- 1.36.0
- 1.37.0
- 1.37.1
- 1.37.2
- 1.4.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.34.2 ∪ ≥ 1.35.0, < 1.37.3
Actualiza a 1.34.2; Actualiza a 1.37.3