CVE-2026-30928
CVE-2026-30928 · Glances Exposes Unauthenticated Configuration Secrets
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.1, the /api/4/config REST API endpoint returns the entire parsed Glances configuration file (glances.conf) via self.config.as_dict() with no filtering of sensitive values. The configuration file contains credentials for all configured backend services including database passwords, API tokens, JWT signing keys, and SSL key passwords. This vulnerability is fixed in 4.5.1.
CVSS 8.7 · Alta · EPSS 1,7% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
glances
- Versiones
- < 4.5.1: Afectada
Sin corrección publicada
glances Debian:13
- Versiones
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- 4.5.1+dfsg-1
- 4.5.2+dfsg-1
- 4.5.3.2+dfsg-1
- 4.5.4+dfsg-1
- 4.5.5+dfsg-1
- 4.5.6+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Debian:14
- Versiones
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.5.1+dfsg-1
Actualiza a 4.5.1+dfsg-1
glances PyPI
- Versiones
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.4
- 1.4.1
- 1.4.1.1
- 1.4.2
- 1.4.2.1
- 1.5
- 1.5.1
- 1.5.2
- 1.6
- 1.6.1
- 1.7
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 2.0
- 2.0.1
- 2.1
- 2.1.1
- 2.1.2
- 2.10
- 2.11
- 2.11.1
- 2.2
- 2.2.1
- 2.3
- 2.4
- 2.4.1
- 2.4.2
- 2.5
- 2.5.1
- 2.6
- 2.6.1
- 2.6.2
- 2.7
- 2.7.1
- 2.8
- 2.8.1
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.9.0
- 2.9.1
- 3.0
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.4.1
- 3.1.5
- 3.1.6
- 3.1.6.1
- 3.1.6.2
- 3.1.7
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.3.1
- 3.2.4
- 3.2.4.1
- 3.2.4.2
- 3.2.5
- 3.2.6.1
- 3.2.6.2
- 3.2.6.3
- 3.2.6.4
- 3.2.7
- 3.3.0
- 3.3.0.1
- 3.3.0.2
- 3.3.0.3
- 3.3.0.4
- 3.3.1
- 3.3.1.1
- 3.4.0
- 3.4.0.1
- 3.4.0.2
- 3.4.0.3
- 3.4.0.4
- 3.4.0.5
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.1.0
- 4.1.1
- 4.1.2
- 4.2.0
- 4.2.1
- 4.3.0
- 4.3.0.1
- 4.3.0.3
- 4.3.0.4
- 4.3.0.5
- 4.3.0.6
- 4.3.0.7
- 4.3.0.8
- 4.3.1
- 4.3.2
- 4.3.3
- 4.4.0
- 4.4.1
- 4.5.0
- 4.5.0.1
- 4.5.0.2
- 4.5.0.3
- 4.5.0.4
- 4.5.0.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.5.1
Actualiza a 4.5.1
glances Ubuntu:Pro:16.04:LTS
- Versiones
- 2.3-1build1
- 2.3-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Ubuntu:Pro:18.04:LTS
- Versiones
- 2.10-2
- 2.11.1-1
- 2.11.1-2
- 2.11.1-3
- 2.11.1-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Ubuntu:Pro:20.04:LTS
- Versiones
- 3.1.0-1
- 3.1.1-1
- 3.1.3-1
- 3.1.3-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Ubuntu:22.04:LTS
- Versiones
- 3.1.5-1
- 3.2.3.1+dfsg-1
- 3.2.4.2+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Ubuntu:24.04:LTS
- Versiones
- 3.4.0.3+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Ubuntu:25.10
- Versiones
- 4.3.0.8+dfsg-1
- 4.3.1+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Ubuntu:26.10
- Versiones
- 4.3.3+dfsg-1
- 4.5.4+dfsg-1
- 4.5.5+dfsg-1
- 4.5.6+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
glances Ubuntu:26.04:LTS
- Versiones
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada