p PatchFirst

CVE-2026-30946

CVE-2026-30946 · Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior 9.5.2-alpha.2 and 8.6.15, an unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. This vulnerability is fixed in 9.5.2-alpha.2 and 8.6.15.

CVSS 8.7 · Alta · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • parse-server

    Versiones
    • < 8.6.15: Afectada
    • >= 9.0.0 < 9.5.2-alpha.2: Afectada

    Sin corrección publicada

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: < 8.6.15

    Actualiza a 8.6.15

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 9.0.0, < 9.5.2-alpha.2

    Actualiza a 9.5.2-alpha.2

Fuentes originales

Comprueba tu servidor →