CVE-2026-3105
CVE-2026-3105 · SQL Injection in Contact Activity API Sorting
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
SummaryThis advisory addresses a SQL injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API. MitigationPlease update to 4.4.19, 5.2.10, 6.0.8, 7.0.1 or later. WorkaroundsNone. ReferencesIf you have any questions or comments about this advisory: Email us at [email protected]
CVSS 7.6 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
mautic
- Versiones
- ≥ >= 2.10.0, < < 4.4.19 <5.2.10 <6.0.8 <7.0.1: Afectada (semver)
Sin corrección publicada
mautic/core Packagist
- Versiones
- 2.10.0
- 2.10.1
- 2.11.0
- 2.11.0-beta
- 2.12.0
- 2.12.0-beta
- 2.12.1
- 2.12.1-beta
- 2.12.2
- 2.12.2-beta
- 2.13.0
- 2.13.0-beta
- 2.13.1
- 2.14.0
- 2.14.0-beta
- 2.14.1
- 2.14.1-beta
- 2.14.2
- 2.14.2-beta
- 2.15.0
- 2.15.0-beta
- 2.15.1
- 2.15.1-beta
- 2.15.2
- 2.15.2-beta
- 2.15.3
- 2.15.3-beta
- 2.16.0
- 2.16.0-beta
- 2.16.1
- 2.16.1-beta
- 2.16.2
- 2.16.2-beta
- 2.16.3
- 2.16.3-beta
- 2.16.4
- 2.16.5
- 3.0.0
- 3.0.0-alpha
- 3.0.0-beta
- 3.0.0-beta2
- 3.0.1
- 3.0.2
- 3.0.2-rc
- 3.1.0
- 3.1.0-rc
- 3.1.1
- 3.1.1-rc
- 3.1.2
- 3.1.2-rc
- 3.2.0
- 3.2.0-rc
- 3.2.1
- 3.2.2
- 3.2.2-rc
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.5-rc
- 3.3.0
- 3.3.0-rc
- 3.3.1
- 3.3.2
- 3.3.2-rc
- 3.3.3
- 3.3.3-rc
- 3.3.4
- 3.3.5
- 4.0.0
- 4.0.0-alpha1
- 4.0.0-beta
- 4.0.0-rc
- 4.0.1
- 4.0.2
- 4.1.0
- 4.1.1
- 4.1.2
- 4.2.0
- 4.2.0-rc
- 4.2.0-rc1
- 4.2.1
- 4.2.2
- 4.3.0
- 4.3.0-beta
- 4.3.0-rc
- 4.3.1
- 4.4.0
- 4.4.0-beta
- 4.4.1
- 4.4.10
- 4.4.11
- 4.4.12
- 4.4.13
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- 5.0.0
- 5.0.0-alpha
- 5.0.0-alpha1
- 5.0.0-beta1
- 5.0.0-beta2
- 5.0.0-rc1
- 5.0.0-rc2
- 5.0.1
- 5.0.2
- 5.0.3
- 5.0.4
- 5.1.0
- 5.1.1
- 5.2.0
- 5.2.1
- 5.2.2
- 5.2.3
- 5.2.4
- 5.2.5
- 5.2.6
- 5.2.7
- 5.2.8
- 5.2.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.10.0, < 5.2.10
Actualiza a 5.2.10
mautic/core Packagist
- Versiones
- 6.0.0
- 6.0.0-alpha
- 6.0.0-beta2
- 6.0.0-rc
- 6.0.1
- 6.0.2
- 6.0.3
- 6.0.4
- 6.0.5
- 6.0.6
- 6.0.7
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.0.0-alpha, < 6.0.8
Actualiza a 6.0.8
mautic/core Packagist
- Versiones
- 7.0.0
- 7.0.0-alpha
- 7.0.0-beta
- 7.0.0-rc
- 7.0.0-rc2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 7.0.0-alpha, < 7.0.1
Actualiza a 7.0.1