CVE-2026-31988
CVE-2026-31988 · yauzl 3.2.0 - Denial of Service via Off-by-One Error in NTFS Timestamp Parser
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
yauzl (aka Yet Another Unzip Library) version 3.2.0 for Node.js contains an off-by-one error in the NTFS extended timestamp extra field parser within the getLastModDate() function. The while loop condition checks cursor < data.length + 4 instead of cursor + 4 <= data.length, allowing readUInt16LE() to read past the buffer boundary. A remote attacker can cause a denial of service (process crash via ERR_OUT_OF_RANGE exception) by sending a crafted zip file with a malformed NTFS extra field. This affects any Node.js application that processes zip file uploads and calls entry.getLastModDate() on parsed entries. Fixed in version 3.2.1.
CVSS 6.9 · Media · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
yauzl
- Versiones
- ≥ 3.2.0, < 3.2.1: Afectada (semver)
- 3.2.1: No afectada
Actualiza a 3.2.1
yauzl npm
- Versiones
- 3.2.0
- Intervalos de versiones afectados
- SEMVER: ≥ 3.2.0, < 3.2.1
Actualiza a 3.2.1
node-yauzl Ubuntu:16.04:LTS
- Versiones
- 2.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-yauzl Ubuntu:18.04:LTS
- Versiones
- 2.1.0-1
- 2.1.0-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-yauzl Ubuntu:20.04:LTS
- Versiones
- 2.10.0-1
- 2.10.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-yauzl Ubuntu:22.04:LTS
- Versiones
- 2.10.0-2
- 2.10.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-yauzl Ubuntu:24.04:LTS
- Versiones
- 2.10.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-yauzl Ubuntu:25.10
- Versiones
- 2.10.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-yauzl Ubuntu:26.10
- Versiones
- 2.10.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-yauzl Ubuntu:26.04:LTS
- Versiones
- 2.10.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/thejoshwolfe/yauzl/commit/c4695215b05c6adffda613b9051a2a85429b33fe
- https://www.codeant.ai/security-research/yauzl-denial-of-service-zip-file-crash
- https://www.npmjs.com/package/yauzl
- https://www.vulncheck.com/advisories/yauzl-denial-of-service-via-off-by-one-error-in-ntfs-timestamp-parser
- https://nvd.nist.gov/vuln/detail/CVE-2026-31988