CVE-2026-33151
CVE-2026-33151 · socket.io allows an unbounded number of binary attachments
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Socket.IO is an open source, real-time, bidirectional, event-based, communication framework. Prior to versions 3.3.5, 3.4.4, and 4.2.6, a specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. This issue has been patched in versions 3.3.5, 3.4.4, and 4.2.6.
CVSS 8.7 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
socket.io
- Versiones
- < 3.3.5: Afectada
- >= 3.4.0, < 3.4.4: Afectada
- >= 4.0.0, < 4.2.6: Afectada
Sin corrección publicada
node-socket.io-parser Debian:12
- Versiones
- 4.2.1+~3.1.0-2
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Debian:13
- Versiones
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Debian:14
- Versiones
- 4.2.1+~3.1.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.2.1+~3.1.0-4
Actualiza a 4.2.1+~3.1.0-4
socket.io-parser npm
- Intervalos de versiones afectados
- SEMVER: < 3.3.5
Actualiza a 3.3.5
socket.io-parser npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.4.0, < 3.4.4
Actualiza a 3.4.4
socket.io-parser npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 4.2.6
Actualiza a 4.2.6
node-socket.io-parser Ubuntu:18.04:LTS
- Versiones
- 2.3.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:20.04:LTS
- Versiones
- 3.3.0-1
- 3.4.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:22.04:LTS
- Versiones
- 4.0.2-1
- 4.1.1+~3.0.0-1
- 4.1.2+~3.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:24.04:LTS
- Versiones
- 4.2.1+~3.1.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:25.10
- Versiones
- 4.2.1+~3.1.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:26.04:LTS
- Versiones
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/socketio/socket.io/security/advisories/GHSA-677m-j7p3-52f9
- https://github.com/socketio/socket.io/commit/719f9ebab0772ffb882bd614b387e585c1aa75d4
- https://github.com/socketio/socket.io/commit/9d39f1f080510f036782f2177fac701cc041faaf
- https://github.com/socketio/socket.io/commit/b25738c416c4e32fbff62ee182afa8f6d0dacf78
- https://nvd.nist.gov/vuln/detail/CVE-2026-33151