p PatchFirst

CVE-2026-33672

CVE-2026-33672 · Picomatch: Method Injection in POSIX Character Classes causes incorrect Glob Matching

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Picomatch is a glob matcher written JavaScript. Versions prior to 4.0.4, 3.0.2, and 2.3.2 are vulnerable to a method injection vulnerability affecting the `POSIX_REGEX_SOURCE` object. Because the object inherits from `Object.prototype`, specially crafted POSIX bracket expressions (e.g., `[[:constructor:]]`) can reference inherited method names. These methods are implicitly converted to strings and injected into the generated regular expression. This leads to incorrect glob matching behavior (integrity impact), where patterns may match unintended filenames. The issue does not enable remote code execution, but it can cause security-relevant logic errors in applications that rely on glob matching for filtering, validation, or access control. All users of affected `picomatch` versions that process untrusted or user-controlled glob patterns are potentially impacted. This issue is fixed in picomatch 4.0.4, 3.0.2 and 2.3.2. Users should upgrade to one of these versions or later, depending on their supported release line. If upgrading is not immediately possible, avoid passing untrusted glob patterns to picomatch. Possible mitigations include sanitizing or rejecting untrusted glob patterns, especially those containing POSIX character classes like `[[:...:]]`; avoiding the use of POSIX bracket expressions if user input is involved; and manually patching the library by modifying `POSIX_REGEX_SOURCE` to use a null prototype.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • picomatch

    Versiones
    • >= 4.0.0, < 4.0.4: Afectada
    • >= 3.0.0, < 3.0.2: Afectada
    • < 2.3.2: Afectada

    Sin corrección publicada

  • node-anymatch Debian:12

    Versiones
    • 3.1.3+~cs4.6.1-2
    • 3.1.3+~cs8.0.5-1
    • 3.1.3+~cs8.0.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-anymatch Debian:13

    Versiones
    • 3.1.3+~cs4.6.1-2
    • 3.1.3+~cs8.0.5-1
    • 3.1.3+~cs8.0.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-anymatch Debian:14

    Versiones
    • 3.1.3+~cs4.6.1-2
    • 3.1.3+~cs8.0.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.3+~cs8.0.6-1

    Actualiza a 3.1.3+~cs8.0.6-1

  • picomatch npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.0.4

    Actualiza a 4.0.4

  • picomatch npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.0.2

    Actualiza a 3.0.2

  • picomatch npm

    Intervalos de versiones afectados
    • SEMVER: < 2.3.2

    Actualiza a 2.3.2

  • node-anymatch Ubuntu:18.04:LTS

    Versiones
    • 1.3.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-anymatch Ubuntu:20.04:LTS

    Versiones
    • 3.0.3+~2.0.7-3
    • 3.1.1+~2.1.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-anymatch Ubuntu:22.04:LTS

    Versiones
    • 3.1.1+~2.2.2-1
    • 3.1.2+~cs4.5.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-anymatch Ubuntu:24.04:LTS

    Versiones
    • 3.1.3+~cs4.6.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-anymatch Ubuntu:25.10

    Versiones
    • 3.1.3+~cs4.6.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-anymatch Ubuntu:26.04:LTS

    Versiones
    • 3.1.3+~cs4.6.1-2
    • 3.1.3+~cs8.0.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →