p PatchFirst

CVE-2026-33749

CVE-2026-33749 · n8n Vulnerable to XSS via Binary Data Inline HTML Rendering

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

n8n is an open source workflow automation platform. Prior to versions 1.123.27, 2.13.3, and 2.14.1, an authenticated user with permission to create or modify workflows could craft a workflow that produces an HTML binary data object without a filename. The `/rest/binary-data` endpoint served such responses inline on the n8n origin without `Content-Disposition` or `Content-Security-Policy` headers, allowing the HTML to render in the browser with full same-origin JavaScript access. By sending the resulting URL to a higher-privileged user, an attacker could execute JavaScript in the victim's authenticated session, enabling exfiltration of workflows and credentials, modification of workflows, or privilege escalation to admin. The issue has been fixed in n8n versions 1.123.27, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or restrict network access to the n8n instance to prevent untrusted users from accessing binary data URLs. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

CVSS 6.3 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • n8n

    Versiones
    • < 1.123.27: Afectada
    • >= 2.0.0-rc.0, < 2.13.3: Afectada
    • = 2.14.0: Afectada

    Sin corrección publicada

  • n8n npm

    Intervalos de versiones afectados
    • SEMVER: < 1.123.27

    Actualiza a 1.123.27

  • n8n npm

    Versiones
    • 2.14.0
    Intervalos de versiones afectados
    • SEMVER: ≥ 2.14.0, < 2.14.1

    Actualiza a 2.14.1

  • n8n npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0-rc.0, < 2.13.3

    Actualiza a 2.13.3

Fuentes originales

Comprueba tu servidor →