CVE-2026-34445
CVE-2026-34445 · ONNX: Malicious ONNX models can crash servers by exploiting unprotected object settings.
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to version 1.21.0, the ExternalDataInfo class in ONNX was using Python’s setattr() function to load metadata (like file paths or data lengths) directly from an ONNX model file. It didn’t check if the "keys" in the file were valid. Due to this, an attacker could craft a malicious model that overwrites internal object properties. This issue has been patched in version 1.21.0.
CVSS 8.6 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
onnx
- Versiones
- < 1.21.0: Afectada
Sin corrección publicada
onnx Debian:12
- Versiones
- 1.12.0-2
- 1.13.1-1
- 1.13.1-2
- 1.13.1-3
- 1.14.1-1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1~exp1
- 1.16.1-1
- 1.16.2-1
- 1.17.0-1
- 1.17.0-2
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Debian:13
- Versiones
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Debian:14
- Versiones
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx PyPI
- Versiones
- 0.1
- 0.2
- 0.2.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.16.1
- 1.16.2
- 1.17.0
- 1.18.0
- 1.19.0
- 1.19.1
- 1.19.1rc1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.1
- 1.20.1rc1
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.0rc4
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.21.0
Actualiza a 1.21.0
onnx Ubuntu:22.04:LTS
- Versiones
- 1.7.0+dfsg-3build1
- 1.7.0+dfsg-3build2
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:Pro:24.04:LTS
- Versiones
- 1.13.1-3
- 1.13.1-3build1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1build1
- 1.14.1-2.1build2
- 1.14.1-2.1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:25.10
- Versiones
- 1.17.0-3build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:26.10
- Versiones
- 1.20.0-1
- 1.20.0-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:26.04:LTS
- Versiones
- 1.17.0-3build1
- 1.20.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada