CVE-2026-34531
CVE-2026-34531 · Flask-HTTPAuth invokes token verification callback when missing or empty token was given by client
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Flask-HTTPAuth provides Basic, Digest and Token HTTP authentication for Flask routes. Prior to version 4.8.1, in a situation where the client makes a request to a token protected resource without passing a token, or passing an empty token, Flask-HTTPAuth would invoke the application's token verification callback function with the token argument set to an empty string. If the application had any users in its database with an empty string set as their token, then it could potentially authenticate the client request against any of those users. This issue has been patched in version 4.8.1.
CVSS 6.5 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
flask-httpauth
- Versiones
- < 4.8.1: Afectada
Sin corrección publicada
python-flask-httpauth Debian:12
- Versiones
- 4.5.0-4
- 4.8.0-1
- 4.8.1-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Debian:13
- Versiones
- 4.8.0-1
- 4.8.1-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Debian:14
- Versiones
- 4.8.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.8.1-1.1
Actualiza a 4.8.1-1.1
flask-httpauth PyPI
- Versiones
- 1.0.0
- 1.1.0
- 2.0.0
- 2.1.0
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.7.0
- 2.7.1
- 2.7.2
- 3.0.0
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 4.0.0
- 4.1.0
- 4.2.0
- 4.3.0
- 4.4.0
- 4.5.0
- 4.6.0
- 4.7.0
- 4.8.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.8.1
Actualiza a 4.8.1
python-flask-httpauth Ubuntu:16.04:LTS
- Versiones
- 2.2.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Ubuntu:18.04:LTS
- Versiones
- 3.2.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Ubuntu:20.04:LTS
- Versiones
- 3.2.4-3
- 3.2.4-3.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Ubuntu:22.04:LTS
- Versiones
- 3.2.4-3.1
- 4.5.0-1
- 4.5.0-2
- 4.5.0-3
- 4.5.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Ubuntu:24.04:LTS
- Versiones
- 4.5.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Ubuntu:25.10
- Versiones
- 4.8.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Ubuntu:26.10
- Versiones
- 4.8.0-1
- 4.8.1-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-flask-httpauth Ubuntu:26.04:LTS
- Versiones
- 4.8.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/miguelgrinberg/Flask-HTTPAuth/security/advisories/GHSA-p44q-vqpr-4xmg
- https://github.com/miguelgrinberg/flask-httpauth/commit/b15ffe9e50e110d7174ccd944f642079e1dcf9ee
- https://github.com/miguelgrinberg/Flask-HTTPAuth/releases/tag/v4.8.1
- https://lists.debian.org/debian-lts-announce/2026/05/msg00049.html
- https://nvd.nist.gov/vuln/detail/CVE-2026-34531