CVE-2026-34544
CVE-2026-34544 · OpenEXR: integer overflow to OOB write in uncompress_b44_impl()
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From version 3.4.0 to before version 3.4.8, a crafted B44 or B44A EXR file can cause an out-of-bounds write in any application that decodes it via exr_decoding_run(). Consequences range from immediate crash (most likely) to corruption of adjacent heap allocations (layout-dependent). This issue has been patched in version 3.4.8.
CVSS 8.4 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
openexr
- Versiones
- >= 3.4.0, < 3.4.8: Afectada
Sin corrección publicada
openexr Debian:12
- Versiones
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openexr Debian:13
- Versiones
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openexr Debian:14
- Versiones
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.4.14-0.1
Actualiza a 3.4.14-0.1
openexr PyPI
- Versiones
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.4.0, < 3.4.8
Actualiza a 3.4.8
openexr PyPI
- Versiones
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.3.0, ≤ 3.3.8
Sin corrección publicada
openexr PyPI
- Versiones
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.2.0, ≤ 3.2.6
Sin corrección publicada
openexr PyPI
- Versiones
- 3.2.10
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- 3.3.0
- 3.3.1
- 3.3.10
- 3.3.11
- 3.3.12
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.3.9
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.2.0, < 3.4.8
Actualiza a 3.4.8
openexr Ubuntu:26.10
- Versiones
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-h762-rhv3-h25v
- https://github.com/AcademySoftwareFoundation/openexr/commit/35e7aa35e22c1975606be86e859f31cc1fc598ee
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.8
- https://nvd.nist.gov/vuln/detail/CVE-2026-34544