CVE-2026-34601
CVE-2026-34601 · xmldom: XML injection via unsafe CDATA serialization allows attacker-controlled markup insertion
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In xmldom versions 0.6.0 and prior and @xmldom/xmldom prior to versions 0.8.12 and 0.9.9, xmldom/xmldom allows attacker-controlled strings containing the CDATA terminator ]]> to be inserted into a CDATASection node. During serialization, XMLSerializer emitted the CDATA content verbatim without rejecting or safely splitting the terminator. As a result, data intended to remain text-only became active XML markup in the serialized output, enabling XML structure injection and downstream business-logic manipulation. This issue has been patched in xmldom version 0.6.0 and @xmldom/xmldom versions 0.8.12 and 0.9.9.
CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
xmldom
- Versiones
- xmldom <= 0.6.0: Afectada
- @xmldom/xmldom < 0.8.12: Afectada
- @xmldom/xmldom >= 0.9.0, < 0.9.9: Afectada
Sin corrección publicada
node-xmldom Debian:12
- Versiones
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Debian:13
- Versiones
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Debian:14
- Versiones
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.9.9-1
Actualiza a 0.9.9-1
xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≤ 0.6.0
Sin corrección publicada
@xmldom/xmldom npm
- Intervalos de versiones afectados
- SEMVER: < 0.8.12
Actualiza a 0.8.12
@xmldom/xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.9.0, < 0.9.9
Actualiza a 0.9.9
node-xmldom Ubuntu:20.04:LTS
- Versiones
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:22.04:LTS
- Versiones
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:24.04:LTS
- Versiones
- 0.8.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:25.10
- Versiones
- 0.9.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:26.10
- Versiones
- 0.9.8-2
- 0.9.10-2
- 0.9.11-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:26.04:LTS
- Versiones
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/xmldom/xmldom/security/advisories/GHSA-wh4c-j3r5-mjhp
- https://github.com/xmldom/xmldom/commit/2b852e836ab86dbbd6cbaf0537f584dd0b5ac184
- https://github.com/xmldom/xmldom/releases/tag/0.8.12
- https://github.com/xmldom/xmldom/releases/tag/0.9.9
- https://access.redhat.com/security/cve/CVE-2026-34601
- https://bugzilla.redhat.com/show_bug.cgi?id=2454595
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34601.json
- https://nvd.nist.gov/vuln/detail/CVE-2026-34601