p PatchFirst

CVE-2026-34989

CVE-2026-34989 · CI4MS affected by Profile & User Management Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to 31.0.0.0, the application fails to properly sanitize user-controlled input when users update their profile name (e.g., full name / username). An attacker can inject a malicious JavaScript payload into their profile name, which is then stored server-side. This stored payload is later rendered unsafely in multiple application views without proper output encoding, leading to stored cross-site scripting (XSS). This vulnerability is fixed in 31.0.0.0.

CVSS 9.4 · Crítica · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • ci4ms

    Versiones
    • < 31.0.0.0: Afectada

    Sin corrección publicada

  • ci4-cms-erp/ci4ms Packagist

    Versiones
    • 0.21.0
    • 0.21.1
    • 0.21.2
    • 0.21.3
    • 0.21.3.1
    • 0.21.3.2
    • 0.21.3.3
    • 0.21.3.4
    • 0.21.3.5
    • 0.21.3.6
    • 0.21.3.7
    • 0.23.0.0
    • 0.23.0.1
    • 0.23.0.2
    • 0.23.1.0
    • 0.24.0.0
    • 0.24.0.16
    • 0.24.0.18
    • 0.24.0.19
    • 0.24.0.20
    • 0.24.0.27
    • 0.24.0.42
    • 0.24.0.45
    • 0.24.0.60
    • 0.25.0.0
    • 0.25.0.1
    • 0.25.0.2
    • 0.25.0.30
    • 0.25.0.39
    • 0.25.0.43
    • 0.25.1.0
    • 0.25.2.0
    • 0.25.3.0
    • 0.26.0.0
    • 0.26.1.0
    • 0.26.2.0
    • 0.26.3.0
    • 0.26.3.1
    • 0.26.3.2
    • 0.26.3.3
    • 0.26.3.4
    • 0.27.0.0
    • 0.28.0.0
    • 0.28.3.0
    • 0.28.4.0
    • 0.28.5.0
    • 0.28.6.0
    • 0.31.0.0
    • 0.31.1.0
    • 0.31.10.0
    • 0.31.11.0
    • 0.31.2.0
    • 0.31.3.0
    • 0.31.4.0
    • 0.31.5.0
    • 0.31.6.0
    • 0.31.7.0
    • 0.31.8.0
    • 0.31.9
    • 0.32.0.0
    • 0.33.1.0
    • 0.33.2.0
    • 0.34.0.0
    • 0.34.1.0
    • 0.35.0.0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 31.0.0.0

    Actualiza a 31.0.0.0

Fuentes originales

Comprueba tu servidor →