p PatchFirst

CVE-2026-35615

CVE-2026-35615 · PraisonAI has a Path Traversal in FileTools

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

PraisonAI is a multi-agent teams system. Prior to 1.5.113, _validate_path() calls os.path.normpath() first, which collapses .. sequences, then checks for '..' in normalized. Since .. is already collapsed, the check always passes. This makes the check completely useless and allows trivial path traversal to any file on the system. This vulnerability is fixed in 1.5.113.

CVSS 9.2 · Crítica · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • praisonai

    Versiones
    • < 4.5.113: Afectada

    Sin corrección publicada

  • praisonai PyPI

    Versiones
    • 0.0.1
    • 0.0.10
    • 0.0.11
    • 0.0.12
    • 0.0.13
    • 0.0.14
    • 0.0.15
    • 0.0.16
    • 0.0.17
    • 0.0.18
    • 0.0.19
    • 0.0.2
    • 0.0.20
    • 0.0.21
    • 0.0.22
    • 0.0.23
    • 0.0.24
    • 0.0.25
    • 0.0.26
    • 0.0.27
    • 0.0.28
    • 0.0.29
    • 0.0.3
    • 0.0.30
    • 0.0.31
    • 0.0.32
    • 0.0.33
    • 0.0.34
    • 0.0.35
    • 0.0.36
    • 0.0.37
    • 0.0.38
    • 0.0.39
    • 0.0.4
    • 0.0.40
    • 0.0.41
    • 0.0.42
    • 0.0.43
    • 0.0.44
    • 0.0.45
    • 0.0.46
    • 0.0.47
    • 0.0.48
    • 0.0.49
    • 0.0.5
    • 0.0.50
    • 0.0.52
    • 0.0.53
    • 0.0.54
    • 0.0.55
    • 0.0.56
    • 0.0.57
    • 0.0.58
    • 0.0.59
    • 0.0.59rc11
    • 0.0.59rc2
    • 0.0.59rc3
    • 0.0.59rc5
    • 0.0.59rc6
    • 0.0.59rc7
    • 0.0.59rc8
    • 0.0.59rc9
    • 0.0.6
    • 0.0.61
    • 0.0.64
    • 0.0.65
    • 0.0.66
    • 0.0.67
    • 0.0.68
    • 0.0.69
    • 0.0.7
    • 0.0.70
    • 0.0.71
    • 0.0.72
    • 0.0.73
    • 0.0.74
    • 0.0.8
    • 0.0.9
    • 0.1.0
    • 0.1.1
    • 0.1.10
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 1.0.0
    • 1.0.1
    • 1.0.10
    • 1.0.11
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.8
    • 1.0.9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.113

    Actualiza a 1.5.113

Fuentes originales

Comprueba tu servidor →