p PatchFirst

CVE-2026-3731

CVE-2026-3731 · libssh SFTP Extension Name sftp.c sftp_extensions_get_data out-of-bounds

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A weakness has been identified in libssh up to 0.11.3. The impacted element is the function sftp_extensions_get_name/sftp_extensions_get_data of the file src/sftp.c of the component SFTP Extension Name Handler. Executing a manipulation of the argument idx can lead to out-of-bounds read. The attack may be performed from remote. Upgrading to version 0.11.4 and 0.12.0 is sufficient to resolve this issue. This patch is called 855a0853ad3abd4a6cd85ce06fce6d8d4c7a0b60. You should upgrade the affected component.

CVSS 6.9 · Media · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • libssh

    Versiones
    • 0.11.0: Afectada
    • 0.11.1: Afectada
    • 0.11.2: Afectada
    • 0.11.3: Afectada
    • 0.11.4: No afectada
    • 0.12.0: No afectada

    Actualiza a 0.11.4

  • libssh Debian:12

    Versiones
    • 0.10.5-2
    • 0.10.5-3
    • 0.10.5-3+hurd.1
    • 0.10.6-0+deb12u1
    • 0.10.6-0+deb12u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.10.6-0+deb12u3

    Actualiza a 0.10.6-0+deb12u3

  • libssh Debian:13

    Versiones
    • 0.11.2-1
    • 0.11.2-1+deb13u1
    • 0.11.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.11.5-0+deb13u1

    Actualiza a 0.11.5-0+deb13u1

  • libssh Debian:14

    Versiones
    • 0.11.2-1
    • 0.11.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.12.0-1

    Actualiza a 0.12.0-1

  • libssh Ubuntu:Pro:16.04:LTS

    Versiones
    • 0.6.3-3ubuntu3
    • 0.6.3-4.1
    • 0.6.3-4.2
    • 0.6.3-4.2ubuntu1
    • 0.6.3-4.3
    • 0.6.3-4.3ubuntu0.1
    • 0.6.3-4.3ubuntu0.2
    • 0.6.3-4.3ubuntu0.5
    • 0.6.3-4.3ubuntu0.6
    • 0.6.3-4.3ubuntu0.6+esm1
    • 0.6.3-4.3ubuntu0.6+esm2
    • 0.6.3-4.3ubuntu0.6+esm3
    • 0.6.3-4.3ubuntu0.6+esm4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.6.3-4.3ubuntu0.6+esm5

    Actualiza a 0.6.3-4.3ubuntu0.6+esm5

  • libssh Ubuntu:Pro:18.04:LTS

    Versiones
    • 0.7.5-1
    • 0.8.0~20170825.94fa1e38-1
    • 0.8.0~20170825.94fa1e38-1build1
    • 0.8.0~20170825.94fa1e38-1ubuntu0.1
    • 0.8.0~20170825.94fa1e38-1ubuntu0.2
    • 0.8.0~20170825.94fa1e38-1ubuntu0.5
    • 0.8.0~20170825.94fa1e38-1ubuntu0.6
    • 0.8.0~20170825.94fa1e38-1ubuntu0.7
    • 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm3
    • 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm4
    • 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm5
    • 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm7

    Actualiza a 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm7

  • libssh Ubuntu:Pro:20.04:LTS

    Versiones
    • 0.9.0-1ubuntu1
    • 0.9.0-1ubuntu4
    • 0.9.0-1ubuntu5
    • 0.9.3-2ubuntu1
    • 0.9.3-2ubuntu2
    • 0.9.3-2ubuntu2.1
    • 0.9.3-2ubuntu2.2
    • 0.9.3-2ubuntu2.3
    • 0.9.3-2ubuntu2.4
    • 0.9.3-2ubuntu2.5
    • 0.9.3-2ubuntu2.5+esm1
    • 0.9.3-2ubuntu2.5+esm2
    • 0.9.3-2ubuntu2.5+esm3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.9.3-2ubuntu2.5+esm4

    Actualiza a 0.9.3-2ubuntu2.5+esm4

  • libssh Ubuntu:22.04:LTS

    Versiones
    • 0.9.6-1
    • 0.9.6-1build1
    • 0.9.6-2
    • 0.9.6-2build1
    • 0.9.6-2ubuntu0.22.04.1
    • 0.9.6-2ubuntu0.22.04.2
    • 0.9.6-2ubuntu0.22.04.3
    • 0.9.6-2ubuntu0.22.04.4
    • 0.9.6-2ubuntu0.22.04.5
    • 0.9.6-2ubuntu0.22.04.6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.9.6-2ubuntu0.22.04.7

    Actualiza a 0.9.6-2ubuntu0.22.04.7

  • libssh Ubuntu:24.04:LTS

    Versiones
    • 0.10.5-3ubuntu1
    • 0.10.5-3ubuntu2
    • 0.10.6-2
    • 0.10.6-2build1
    • 0.10.6-2build2
    • 0.10.6-2ubuntu0.1
    • 0.10.6-2ubuntu0.2
    • 0.10.6-2ubuntu0.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.10.6-2ubuntu0.4

    Actualiza a 0.10.6-2ubuntu0.4

  • libssh Ubuntu:25.10

    Versiones
    • 0.11.1-1
    • 0.11.1-2
    • 0.11.2-1
    • 0.11.2-1build1
    • 0.11.2-1ubuntu0.1
    • 0.11.2-1ubuntu0.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.11.2-1ubuntu0.3

    Actualiza a 0.11.2-1ubuntu0.3

  • libssh Ubuntu:26.04:LTS

    Versiones
    • 0.11.2-1build1
    • 0.11.3-1
    • 0.11.3-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.11.3-1ubuntu2

    Actualiza a 0.11.3-1ubuntu2

Fuentes originales

Comprueba tu servidor →