CVE-2026-40083
CVE-2026-40083 · Cacti: SQL Injection in managers.php
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have SQL Injection through unsanitized unserialize+implode in managers.php. At line 756 of managers.php, the application assigns $selected_items by calling cacti_unserialize(stripslashes(gnrv('selected_graphs_array'))). The cacti_unserialize() function calls unserialize() with allowed_classes set to false, which prevents object injection but still allows arbitrary string arrays to be deserialized. Then, at lines 760 to 766, the deserialized array values are passed directly into db_execute('DELETE FROM snmpagent_managers WHERE id IN (' . implode(',', $selected_items) . ')'), where they are imploded into the SQL statement without any integer validation, resulting in SQL Injection when using SNMP agent management permissions. This issue has been fixed in version 1.2.31.
CVSS 7.2 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
cacti
- Versiones
- < 1.2.31: Afectada
Sin corrección publicada
cacti Debian:12
- Versiones
- 1.2.24+ds1-1
- 1.2.24+ds1-1+deb12u1
- 1.2.24+ds1-1+deb12u2
- 1.2.24+ds1-1+deb12u3
- 1.2.24+ds1-1+deb12u4
- 1.2.24+ds1-1+deb12u5
- 1.2.25+ds1-1
- 1.2.25+ds1-2
- 1.2.26+ds1-1
- 1.2.27+ds1-1
- 1.2.27+ds1-2
- 1.2.28+ds1-1
- 1.2.28+ds1-2
- 1.2.28+ds1-3
- 1.2.28+ds1-4
- 1.2.30+ds1-1
- 1.2.30+ds1-2
- 1.2.30+ds1-3
- 1.2.31+ds1-1
- 1.2.31+ds1-2
- 1.2.31+ds1-3
- 1.2.31+ds1-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Debian:13
- Versiones
- 1.2.30+ds1-1
- 1.2.30+ds1-2
- 1.2.30+ds1-3
- 1.2.31+ds1-1
- 1.2.31+ds1-2
- 1.2.31+ds1-3
- 1.2.31+ds1-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Debian:14
- Versiones
- 1.2.30+ds1-1
- 1.2.30+ds1-2
- 1.2.30+ds1-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.31+ds1-1
Actualiza a 1.2.31+ds1-1
cacti Ubuntu:Pro:14.04:LTS
- Versiones
- 0.8.8b+dfsg-3
- 0.8.8b+dfsg-5
- 0.8.8b+dfsg-5ubuntu0.1
- 0.8.8b+dfsg-5ubuntu0.2
- 0.8.8b+dfsg-5ubuntu0.2+esm1
- 0.8.8b+dfsg-5ubuntu0.2+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:Pro:16.04:LTS
- Versiones
- 0.8.8f+ds1-2
- 0.8.8f+ds1-3
- 0.8.8f+ds1-4
- 0.8.8f+ds1-4ubuntu1
- 0.8.8f+ds1-4ubuntu2
- 0.8.8f+ds1-4ubuntu3
- 0.8.8f+ds1-4ubuntu4
- 0.8.8f+ds1-4ubuntu4.16.04
- 0.8.8f+ds1-4ubuntu4.16.04.1
- 0.8.8f+ds1-4ubuntu4.16.04.2
- 0.8.8f+ds1-4ubuntu4.16.04.2+esm1
- 0.8.8f+ds1-4ubuntu4.16.04.2+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:Pro:18.04:LTS
- Versiones
- 1.1.18+ds1-1
- 1.1.27+ds1-2
- 1.1.27+ds1-3
- 1.1.28+ds1-2
- 1.1.35+ds1-1
- 1.1.36+ds1-1
- 1.1.38+ds1-1
- 1.1.38+ds1-1ubuntu0.1~esm1
- 1.1.38+ds1-1ubuntu0.1~esm3
- 1.1.38+ds1-1ubuntu0.1~esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:Pro:20.04:LTS
- Versiones
- 1.2.4+ds1-2ubuntu3
- 1.2.9+ds1-1ubuntu1
- 1.2.9+ds1-1ubuntu2
- 1.2.10+ds1-1ubuntu1
- 1.2.10+ds1-1ubuntu1+esm1
- 1.2.10+ds1-1ubuntu1.1
- 1.2.10+ds1-1ubuntu1.1+esm1
- 1.2.10+ds1-1ubuntu1.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:Pro:22.04:LTS
- Versiones
- 1.2.16+ds1-2ubuntu1
- 1.2.19+ds1-2ubuntu1
- 1.2.19+ds1-2ubuntu1+esm1
- 1.2.19+ds1-2ubuntu1.1
- 1.2.19+ds1-2ubuntu1.1+esm1
- 1.2.19+ds1-2ubuntu1.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:24.04:LTS
- Versiones
- 1.2.25+ds1-2
- 1.2.26+ds1-1
- 1.2.26+ds1-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:25.10
- Versiones
- 1.2.28+ds1-4ubuntu1
- 1.2.30+ds1-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:26.10
- Versiones
- 1.2.30+ds1-1ubuntu2
- 1.2.30+ds1-1ubuntu3
- 1.2.31+ds1-3ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cacti Ubuntu:26.04:LTS
- Versiones
- 1.2.30+ds1-1ubuntu1
- 1.2.30+ds1-1ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada