CVE-2026-41066
CVE-2026-41066 · lxml: Default configuration of iterparse() and ETCompatXMLParser() allows XXE to local files
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
lxml is a library for processing XML and HTML in the Python language. Prior to 6.1.0, using either of the two parsers in the default configuration (with resolve_entities=True) allows untrusted XML input to read local files. Setting the resolve_entities option explicitly to resolve_entities='internal' or resolve_entities=False disables the local file access. This vulnerability is fixed in 6.1.0.
CVSS 7.5 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
lxml
- Versiones
- < 6.1.0: Afectada
Sin corrección publicada
lxml Debian:12
- Versiones
- 4.9.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.9.2-1+deb12u1
Actualiza a 4.9.2-1+deb12u1
lxml Debian:13
- Versiones
- 5.4.0-1
- 6.0.1-1
- 6.0.2-1
- 6.1.0-1
- 6.1.3-1
- 7.0.0~a2-1
- 7.0.0~b1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lxml Debian:14
- Versiones
- 5.4.0-1
- 6.0.1-1
- 6.0.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.1.0-1
Actualiza a 6.1.0-1
lxml PyPI
- Versiones
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 2.0
- 2.0.10
- 2.0.11
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.2
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 3.0
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.5.0
- 3.6.0
- 3.6.1
- 3.6.2
- 3.6.3
- 3.6.4
- 3.7.0
- 3.7.1
- 3.7.2
- 3.7.3
- 3.8.0
- 4.0.0
- 4.1.0
- 4.1.1
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.3.0
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.5.0
- 4.5.1
- 4.5.2
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- 4.7.1
- 4.8.0
- 4.9.0
- 4.9.1
- 4.9.2
- 4.9.3
- 4.9.4
- 5.0.0
- 5.0.1
- 5.0.2
- 5.1.0
- 5.1.1
- 5.2.0
- 5.2.1
- 5.2.2
- 5.3.0
- 5.3.1
- 5.3.2
- 5.4.0
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.0.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.1.0
Actualiza a 6.1.0
lxml Ubuntu:Pro:14.04:LTS
- Versiones
- 3.2.0-1
- 3.3.0~beta2-1
- 3.3.0~beta4-1
- 3.3.1-1
- 3.3.2-1
- 3.3.2-1build1
- 3.3.3-1
- 3.3.3-1ubuntu0.1
- 3.3.3-1ubuntu0.2
- 3.3.3-1ubuntu0.2+esm1
- 3.3.3-1ubuntu0.2+esm2
- 3.3.3-1ubuntu0.2+esm3
- 3.3.3-1ubuntu0.2+esm5
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.3.3-1ubuntu0.2+esm6
Actualiza a 3.3.3-1ubuntu0.2+esm6
lxml Ubuntu:Pro:16.04:LTS
- Versiones
- 3.4.4-1
- 3.5.0-1
- 3.5.0-1build1
- 3.5.0-1ubuntu0.1
- 3.5.0-1ubuntu0.2
- 3.5.0-1ubuntu0.3
- 3.5.0-1ubuntu0.4
- 3.5.0-1ubuntu0.4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.0-1ubuntu0.4+esm3
Actualiza a 3.5.0-1ubuntu0.4+esm3
lxml Ubuntu:Pro:18.04:LTS
- Versiones
- 4.0.0-1
- 4.1.0-1
- 4.2.0-1
- 4.2.1-1
- 4.2.1-1ubuntu0.1
- 4.2.1-1ubuntu0.2
- 4.2.1-1ubuntu0.3
- 4.2.1-1ubuntu0.4
- 4.2.1-1ubuntu0.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.2.1-1ubuntu0.6+esm1
Actualiza a 4.2.1-1ubuntu0.6+esm1
lxml Ubuntu:Pro:20.04:LTS
- Versiones
- 4.4.1-1
- 4.4.1-1build1
- 4.4.2-1
- 4.5.0-1
- 4.5.0-1ubuntu0.1
- 4.5.0-1ubuntu0.2
- 4.5.0-1ubuntu0.3
- 4.5.0-1ubuntu0.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.5.0-1ubuntu0.5+esm1
Actualiza a 4.5.0-1ubuntu0.5+esm1
lxml Ubuntu:22.04:LTS
- Versiones
- 4.6.3+dfsg-0.1
- 4.6.4-1
- 4.6.4-1ubuntu1
- 4.7.1-1
- 4.8.0-1
- 4.8.0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.8.0-1ubuntu0.1
Actualiza a 4.8.0-1ubuntu0.1
lxml Ubuntu:24.04:LTS
- Versiones
- 4.9.3-1
- 4.9.3-1build1
- 4.9.4-1
- 5.1.0-1
- 5.1.0-1build1
- 5.1.0-1build2
- 5.2.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.2.1-1ubuntu0.2
Actualiza a 5.2.1-1ubuntu0.2
lxml Ubuntu:25.10
- Versiones
- 5.3.2-1
- 5.4.0-1
- 5.4.0-1build1
- 6.0.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lxml Ubuntu:26.04:LTS
- Versiones
- 6.0.1-1
- 6.0.1-1build1
- 6.0.2-1
- 6.0.2-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.2-1ubuntu0.1
Actualiza a 6.0.2-1ubuntu0.1