CVE-2026-41149
CVE-2026-41149 · Mermaid: Improper sanitization of `classDef` in state diagrams leads to HTML injection
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and earlier, as well as 11.0.0-alpha.1 through 11.14.0, are vulnerable to HTML injection under the default configuration. Specifically, the classDef directive in Mermaid state diagrams permits DOM injection that escapes the SVG context. However, <script> tags are stripped, which prevents cross-site scripting (XSS). This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting "securityLevel": "sandbox", which prevents the issue by rendering the mermaid diagram in a sandboxed <iframe>.
CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
mermaid
- Versiones
- >= 11.0.0-alpha.1, < 11.15.0: Afectada
- < 10.9.6: Afectada
Sin corrección publicada
node-mermaid Debian:14
- Versiones
- 8.11.0+ds+~cs29.13.22-1
- 8.13.2+ds+~cs30.13.21-1
- 8.13.2+ds+~cs30.13.21-1.1
- 8.13.3+ds+~cs26.13.21-1
- 8.13.3+ds+~cs26.13.21-2
- 8.13.8+~cs10.4.16-1
- 8.14.0+ds1+~cs11.4.14-1
- 8.14.0+~cs11.4.14-1
- 8.7.0+ds+~cs27.17.17-1
- 8.7.0+ds+~cs27.17.17-2
- 8.7.0+ds+~cs27.17.17-2~bpo10+1
- 8.7.0+ds+~cs27.17.17-3
- 8.9.1+ds+~cs26.20.25-1
- 8.9.3+ds+~cs29.13.19-1
- 9.2.2+~2.0.0-1
- 9.2.2+~2.0.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mermaid npm
- Intervalos de versiones afectados
- SEMVER: ≥ 11.0.0-alpha.1, < 11.15.0
Actualiza a 11.15.0
mermaid npm
- Intervalos de versiones afectados
- SEMVER: < 10.9.6
Actualiza a 10.9.6
node-mermaid Ubuntu:22.04:LTS
- Versiones
- 8.7.0+ds+~cs27.17.17-3
- 8.13.3+ds+~cs26.13.21-1
- 8.13.3+ds+~cs26.13.21-2
- 8.13.8+~cs10.4.16-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-mermaid Ubuntu:26.10
- Versiones
- 9.2.2+~2.0.0-1
- 9.2.2+~2.0.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada