p PatchFirst

CVE-2026-41150

CVE-2026-41150 · Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.6 and 11.15.0, there is a denial-of-service attack when rendering gantt charts, if they use the excludes attribute to exclude all dates. mermaid.parse is unaffected, unless you then call the ganttDb.getTasks() (which is called when rendering a diagram). This vulnerability is fixed in 10.9.6 and 11.15.0.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • mermaid

    Versiones
    • >= 11.0.0-alpha.1, < 11.15.0: Afectada
    • < 10.9.6: Afectada

    Sin corrección publicada

  • node-mermaid Debian:14

    Versiones
    • 8.11.0+ds+~cs29.13.22-1
    • 8.13.2+ds+~cs30.13.21-1
    • 8.13.2+ds+~cs30.13.21-1.1
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    • 8.14.0+ds1+~cs11.4.14-1
    • 8.14.0+~cs11.4.14-1
    • 8.7.0+ds+~cs27.17.17-1
    • 8.7.0+ds+~cs27.17.17-2
    • 8.7.0+ds+~cs27.17.17-2~bpo10+1
    • 8.7.0+ds+~cs27.17.17-3
    • 8.9.1+ds+~cs26.20.25-1
    • 8.9.3+ds+~cs29.13.19-1
    • 9.2.2+~2.0.0-1
    • 9.2.2+~2.0.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mermaid npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 11.0.0-alpha.1, < 11.15.0

    Actualiza a 11.15.0

  • mermaid npm

    Intervalos de versiones afectados
    • SEMVER: < 10.9.6

    Actualiza a 10.9.6

  • node-mermaid Ubuntu:22.04:LTS

    Versiones
    • 8.7.0+ds+~cs27.17.17-3
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-mermaid Ubuntu:26.10

    Versiones
    • 9.2.2+~2.0.0-1
    • 9.2.2+~2.0.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →