CVE-2026-41205
CVE-2026-41205 · Mako: Path traversal via double-slash URI prefix in TemplateLookup
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Mako is a template library written in Python. Prior to 1.3.11, TemplateLookup.get_template() is vulnerable to path traversal when a URI starts with // (e.g., //../../../secret.txt). The root cause is an inconsistency between two slash-stripping implementations. Any file readable by the process can be returned as rendered template content when an application passes untrusted input directly to TemplateLookup.get_template(). This vulnerability is fixed in 1.3.11.
CVSS 7.7 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
mako
- Versiones
- < 1.3.11: Afectada
Sin corrección publicada
mako Debian:12
- Versiones
- 1.2.4+ds-1
- 1.2.4+ds-2
- 1.3.1-1
- 1.3.10-1
- 1.3.10-2
- 1.3.10-3
- 1.3.2-1
- 1.3.5-1
- 1.3.5-1.1
- 1.3.6-1
- 1.3.8-1
- 1.3.8-2
- 1.3.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mako Debian:13
- Versiones
- 1.3.10-1
- 1.3.10-2
- 1.3.10-3
- 1.3.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mako Debian:14
- Versiones
- 1.3.10-1
- 1.3.10-2
- 1.3.10-3
- 1.3.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mako PyPI
- Versiones
- 0.1.0
- 0.1.1
- 0.1.10
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.6.0
- 0.6.1
- 0.6.2
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.9.0
- 0.9.1
- 1.0.0
- 1.0.1
- 1.0.10
- 1.0.11
- 1.0.12
- 1.0.13
- 1.0.14
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.2.0
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- 1.3.0
- 1.3.1
- 1.3.10
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.3.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.11
Actualiza a 1.3.11
mako Ubuntu:Pro:16.04:LTS
- Versiones
- 1.0.2+ds1-1
- 1.0.3+ds1-1
- 1.0.3+ds1-1ubuntu1
- 1.0.3+ds1-1ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.3+ds1-1ubuntu1+esm2
Actualiza a 1.0.3+ds1-1ubuntu1+esm2
mako Ubuntu:Pro:18.04:LTS
- Versiones
- 1.0.7+ds1-1
- 1.0.7+ds1-1ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.7+ds1-1ubuntu0.2+esm1
Actualiza a 1.0.7+ds1-1ubuntu0.2+esm1
mako Ubuntu:Pro:20.04:LTS
- Versiones
- 1.0.7+ds1-1
- 1.1.0+ds1-1
- 1.1.0+ds1-1ubuntu1
- 1.1.0+ds1-1ubuntu2
- 1.1.0+ds1-1ubuntu2.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.0+ds1-1ubuntu2.1+esm1
Actualiza a 1.1.0+ds1-1ubuntu2.1+esm1
mako Ubuntu:22.04:LTS
- Versiones
- 1.1.3+ds1-2
- 1.1.3+ds1-2ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.3+ds1-2ubuntu0.2
Actualiza a 1.1.3+ds1-2ubuntu0.2
mako Ubuntu:24.04:LTS
- Versiones
- 1.2.4+ds-2
- 1.3.1-1
- 1.3.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.2-1ubuntu0.1
Actualiza a 1.3.2-1ubuntu0.1
mako Ubuntu:25.10
- Versiones
- 1.3.8-2
- 1.3.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.9-1ubuntu0.1
Actualiza a 1.3.9-1ubuntu0.1
mako Ubuntu:26.04:LTS
- Versiones
- 1.3.9-1
- 1.3.10-3
- 1.3.10-3build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.10-3ubuntu0.1
Actualiza a 1.3.10-3ubuntu0.1