p PatchFirst

CVE-2026-41691

CVE-2026-41691 · i18next-http-backend has Path Traversal & URL Injection via Unsanitised lng/ns

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Copilot said: i18nextify is a JavaScript library that adds i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 3.0.5 interpolate the lng and ns values directly into the configured loadPath / addPath URL template without any encoding, validation, or path sanitisation. When an application exposes the language-code selection to user-controlled input (the default — i18next-browser-languagedetector reads ?lng= query params, cookies, localStorage, and request headers), an attacker can inject characters that change the structure of the outgoing request URL. This is a single URL-injection vulnerability. The attacker-controlled value is neutralised before it is used as part of an output URL string; the attack shape covers both path traversal and broader URL-structure injection — both are closed by the one interpolateUrl sanitisation fix. This issue has been fixed in version 3.0.5. If users cannot upgrade immediately, they can work around the issue by sanitising lng / ns before they reach i18next (strip .., /, \, ?, #, %, whitespace, and control characters; cap the length).

CVSS 6.5 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • i18next-http-backend

    Versiones
    • < 3.0.5: Afectada

    Sin corrección publicada

  • node-i18next-http-backend Debian:12

    Versiones
    • 2.1.1-1
    • 2.4.1+ds-1
    • 2.4.1+ds-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-i18next-http-backend Debian:13

    Versiones
    • 2.4.1+ds-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-i18next-http-backend Debian:14

    Versiones
    • 2.4.1+ds-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • i18next-http-backend npm

    Intervalos de versiones afectados
    • SEMVER: < 3.0.5

    Actualiza a 3.0.5

Fuentes originales

Comprueba tu servidor →